You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "Dongjin Lee (Jira)" <ji...@apache.org> on 2020/01/03 01:50:00 UTC

[jira] [Resolved] (KAFKA-8553) Kafka Connect Schema Compatibility Checks for Name Changes

     [ https://issues.apache.org/jira/browse/KAFKA-8553?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dongjin Lee resolved KAFKA-8553.
--------------------------------
    Resolution: Not A Problem

In Kafka Connect, there are two kinds of 'schema's:

1. Avro schema, which is used in serializing/deserializing Kafka Records (i.e., {{ProducerRecord}}, {{ConsumerRecord}})
 2. Connect schema, which is used to support the Transformer feature (i.e., {{ConnectRecord}}).

To support the evolution of second type schemas, Kafka Connect provides utility functions like {{SchemaProjector#project}}. Since this schema has nothing to do with Avro schema, it has a totally different notion of compatibility. (I agree, it is easy to confusing.)

> Kafka Connect Schema Compatibility Checks for Name Changes
> ----------------------------------------------------------
>
>                 Key: KAFKA-8553
>                 URL: https://issues.apache.org/jira/browse/KAFKA-8553
>             Project: Kafka
>          Issue Type: Bug
>          Components: KafkaConnect
>            Reporter: Omer van Kloeten
>            Priority: Major
>         Attachments: foo1.png, image-2019-06-18-14-59-54-643.png
>
>
> {{SchemaProjector.checkMaybeCompatible}} checks whether the Connect schema is compatible with another one. This is used for projection when using {{schema.compatibility}}.
> Unfortunately, nowhere is it documented that if you change the name of the schema, this would break compatibility entirely.
> For instance, the following two Avro schemas are fully compatible, but Connect says they're not:
> !foo1.png!!image-2019-06-18-14-59-54-643.png!
> This is either the expected behavior and is not documented or unexpected behavior and is an issue with the implementation.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)