You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "brian (JIRA)" <ji...@apache.org> on 2009/04/16 19:09:15 UTC

[jira] Issue Comment Edited: (HADOOP-398) refactor the mapred package into small pieces

    [ https://issues.apache.org/jira/browse/HADOOP-398?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12699765#action_12699765 ] 

brian edited comment on HADOOP-398 at 4/16/09 10:09 AM:
--------------------------------------------------------

In addition to the splits by Owen above, I would also suggest the following package restructuring

package org.apache.hadoop.mapred.sequence;

SequenceFileAsBinaryInputFormat
SequenceFileAsBinaryOutputFormat
SequenceFileAsTextInputFormat
SequenceFileAsTextRecordReader
SequenceFileInputFilter
SequenceFileInputFormat
SequenceFileOutputFormat
SequenceFileRecordReader


package org.apache.hadoop.mapred.file;

FileAlreadyExistsException
FileInputFormat
FileOutputCommitter
FileOutputFormat
FileSplit
IFile
IFileInputStream
IFileOutputStream


      was (Author: brianmackay):
    i would also suggest the following package restructuring

package org.apache.hadoop.mapred.sequence;

SequenceFileAsBinaryInputFormat
SequenceFileAsBinaryOutputFormat
SequenceFileAsTextInputFormat
SequenceFileAsTextRecordReader
SequenceFileInputFilter
SequenceFileInputFormat
SequenceFileOutputFormat
SequenceFileRecordReader


package org.apache.hadoop.mapred.file;

FileAlreadyExistsException
FileInputFormat
FileOutputCommitter
FileOutputFormat
FileSplit
IFile
IFileInputStream
IFileOutputStream

  
> refactor the mapred package into small pieces
> ---------------------------------------------
>
>                 Key: HADOOP-398
>                 URL: https://issues.apache.org/jira/browse/HADOOP-398
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.4.0
>            Reporter: Owen O'Malley
>            Assignee: Owen O'Malley
>
> The mapred package has gotten too big, so I propose changing it to split it into parts.
> I propose the following splits:
> org.apache.hadoop.mapred = client API
> org.apache.hadoop.mapred.task = code for task tracker
> org.apache.hadoop.mapred.job = code for job tracker
> org.apache.hadoop.mapred.utils = non public code that is shared between the servers
> Does anyone have any other divisions that would help?
> I would make the classes sent through RPC public classes in the server's package.
> Thoughts?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.