You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@camel.apache.org by "Claus Ibsen (JIRA)" <ji...@apache.org> on 2010/04/14 15:40:43 UTC

[jira] Created: (CAMEL-2645) camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy

camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy
--------------------------------------------------------------------------------------------------------------------------------------------

                 Key: CAMEL-2645
                 URL: https://issues.apache.org/activemq/browse/CAMEL-2645
             Project: Apache Camel
          Issue Type: Improvement
          Components: camel-http
    Affects Versions: 2.2.0, 2.1.0, 2.0.0
            Reporter: Claus Ibsen
            Assignee: Claus Ibsen
             Fix For: 2.3.0


camel-http uses {{username}} and {{password}} uri parameters for BASIC / NTML authentication.

Its not uncommon for other end users to use those parameters when calling an external http service and thus we should rename them to {{authUsername}} and {{authPassword}} to avoid this common clash.

Also introduce a {{authMethod}} option to let end user select auth of choice
- Basic
- Digest
- NTML

And also we need separate parameters for authenticate the proxy if end users uses that.

And the HttpComponent should have a {{HttpConfiguration}} so end users much easily can setup these options at a component level.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Commented: (CAMEL-2645) camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy

Posted by "Claus Ibsen (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/CAMEL-2645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=58836#action_58836 ] 

Claus Ibsen commented on CAMEL-2645:
------------------------------------

trunk: 933947

Needs to be ported into camel-http4 also

> camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy
> --------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-2645
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-2645
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-http
>    Affects Versions: 2.0.0, 2.1.0, 2.2.0
>            Reporter: Claus Ibsen
>            Assignee: Claus Ibsen
>             Fix For: 2.3.0
>
>
> camel-http uses {{username}} and {{password}} uri parameters for BASIC / NTML authentication.
> Its not uncommon for other end users to use those parameters when calling an external http service and thus we should rename them to {{authUsername}} and {{authPassword}} to avoid this common clash.
> Also introduce a {{authMethod}} option to let end user select auth of choice
> - Basic
> - Digest
> - NTML
> And also we need separate parameters for authenticate the proxy if end users uses that.
> And the HttpComponent should have a {{HttpConfiguration}} so end users much easily can setup these options at a component level.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Commented: (CAMEL-2645) camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy

Posted by "Claus Ibsen (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/CAMEL-2645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=58857#action_58857 ] 

Claus Ibsen commented on CAMEL-2645:
------------------------------------

Add support for auth priority
{code}
List authPrefs = new ArrayList(2);
authPrefs.add(AuthPolicy.DIGEST);
authPrefs.add(AuthPolicy.BASIC);
// This will exclude the NTLM authentication scheme
client.getParams().setParameter(AuthPolicy.AUTH_SCHEME_PRIORITY, authPrefs);
{code}

> camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy
> --------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-2645
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-2645
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-http
>    Affects Versions: 2.0.0, 2.1.0, 2.2.0
>            Reporter: Claus Ibsen
>            Assignee: Claus Ibsen
>             Fix For: 2.3.0
>
>
> camel-http uses {{username}} and {{password}} uri parameters for BASIC / NTML authentication.
> Its not uncommon for other end users to use those parameters when calling an external http service and thus we should rename them to {{authUsername}} and {{authPassword}} to avoid this common clash.
> Also introduce a {{authMethod}} option to let end user select auth of choice
> - Basic
> - Digest
> - NTML
> And also we need separate parameters for authenticate the proxy if end users uses that.
> And the HttpComponent should have a {{HttpConfiguration}} so end users much easily can setup these options at a component level.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Resolved: (CAMEL-2645) camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy

Posted by "Claus Ibsen (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/activemq/browse/CAMEL-2645?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Claus Ibsen resolved CAMEL-2645.
--------------------------------

    Resolution: Fixed

trunk: 934334.

> camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy
> --------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-2645
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-2645
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-http
>    Affects Versions: 2.0.0, 2.1.0, 2.2.0
>            Reporter: Claus Ibsen
>            Assignee: Claus Ibsen
>             Fix For: 2.3.0
>
>
> camel-http uses {{username}} and {{password}} uri parameters for BASIC / NTML authentication.
> Its not uncommon for other end users to use those parameters when calling an external http service and thus we should rename them to {{authUsername}} and {{authPassword}} to avoid this common clash.
> Also introduce a {{authMethod}} option to let end user select auth of choice
> - Basic
> - Digest
> - NTML
> And also we need separate parameters for authenticate the proxy if end users uses that.
> And the HttpComponent should have a {{HttpConfiguration}} so end users much easily can setup these options at a component level.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Commented: (CAMEL-2645) camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy

Posted by "Claus Ibsen (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/activemq/browse/CAMEL-2645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=58898#action_58898 ] 

Claus Ibsen commented on CAMEL-2645:
------------------------------------

trunk: 934699.

> camel-http - Rework option to avoid clash with username and password for auth setting and introduce authMethod option to selecth auth policy
> --------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-2645
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-2645
>             Project: Apache Camel
>          Issue Type: Improvement
>          Components: camel-http
>    Affects Versions: 2.0.0, 2.1.0, 2.2.0
>            Reporter: Claus Ibsen
>            Assignee: Claus Ibsen
>             Fix For: 2.3.0
>
>
> camel-http uses {{username}} and {{password}} uri parameters for BASIC / NTML authentication.
> Its not uncommon for other end users to use those parameters when calling an external http service and thus we should rename them to {{authUsername}} and {{authPassword}} to avoid this common clash.
> Also introduce a {{authMethod}} option to let end user select auth of choice
> - Basic
> - Digest
> - NTML
> And also we need separate parameters for authenticate the proxy if end users uses that.
> And the HttpComponent should have a {{HttpConfiguration}} so end users much easily can setup these options at a component level.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/activemq/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira