You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@qpid.apache.org by "Tomas Restrepo (JIRA)" <qp...@incubator.apache.org> on 2007/01/23 04:00:49 UTC

[jira] Created: (QPID-312) Inconsistency in naming conventions

Inconsistency in naming conventions
-----------------------------------

                 Key: QPID-312
                 URL: https://issues.apache.org/jira/browse/QPID-312
             Project: Qpid
          Issue Type: Improvement
          Components: Dot Net Client
    Affects Versions: M2
            Reporter: Tomas Restrepo
            Priority: Trivial


There is some inconsistency at this time naming conventions that would be good to resolve:

1- Some interfaces still have their original java-like name without the I prefix, which is the usual .NET convention. Examples: ByteBufferAllocator, BrokerInfo, ConnectionInfo
2- Some classes that use the Amq prefix while others most use AMQ (like AmqBrokerInfo and AmqChannel). The latter is the recommended convention by FxCop, but it doesn't matter much as long as we're consistent.
3- A lot of classes ported from Java still have methods named using the original java convention (camelCase).
4- Some namespaces are stil in camelCase (example Qpid.Client.qms)

At least for 2 we should decide what the convention will be so that code can be adapted and be consistent in this regard.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (QPID-312) Inconsistency in naming conventions

Posted by "Rupert Smith (JIRA)" <qp...@incubator.apache.org>.
    [ https://issues.apache.org/jira/browse/QPID-312?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12468231 ] 

Rupert Smith commented on QPID-312:
-----------------------------------

I had problems applying this patch. In particular the file:

IByteBufferAllocator.cs could not be found in the repository. Presumably this is because it was renamed from ByteBufferAllocator.cs. I will apply the changes in this file by hand.

Other than that, it is a fine patch. Good to see the comments taking shape.

> Inconsistency in naming conventions
> -----------------------------------
>
>                 Key: QPID-312
>                 URL: https://issues.apache.org/jira/browse/QPID-312
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Dot Net Client
>    Affects Versions: M2
>            Reporter: Tomas Restrepo
>            Priority: Trivial
>         Attachments: QPID-312.diff
>
>
> There is some inconsistency at this time naming conventions that would be good to resolve:
> 1- Some interfaces still have their original java-like name without the I prefix, which is the usual .NET convention. Examples: ByteBufferAllocator, BrokerInfo, ConnectionInfo
> 2- Some classes that use the Amq prefix while others most use AMQ (like AmqBrokerInfo and AmqChannel). The latter is the recommended convention by FxCop, but it doesn't matter much as long as we're consistent.
> 3- A lot of classes ported from Java still have methods named using the original java convention (camelCase).
> 4- Some namespaces are stil in camelCase (example Qpid.Client.qms)
> At least for 2 we should decide what the convention will be so that code can be adapted and be consistent in this regard.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (QPID-312) Inconsistency in naming conventions

Posted by "Robert Greig (JIRA)" <qp...@incubator.apache.org>.
     [ https://issues.apache.org/jira/browse/QPID-312?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Robert Greig resolved QPID-312.
-------------------------------

       Resolution: Fixed
    Fix Version/s: M2

Patch applied svn revision 501006

> Inconsistency in naming conventions
> -----------------------------------
>
>                 Key: QPID-312
>                 URL: https://issues.apache.org/jira/browse/QPID-312
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Dot Net Client
>    Affects Versions: M2
>            Reporter: Tomas Restrepo
>            Priority: Trivial
>             Fix For: M2
>
>         Attachments: QPID-312.diff
>
>
> There is some inconsistency at this time naming conventions that would be good to resolve:
> 1- Some interfaces still have their original java-like name without the I prefix, which is the usual .NET convention. Examples: ByteBufferAllocator, BrokerInfo, ConnectionInfo
> 2- Some classes that use the Amq prefix while others most use AMQ (like AmqBrokerInfo and AmqChannel). The latter is the recommended convention by FxCop, but it doesn't matter much as long as we're consistent.
> 3- A lot of classes ported from Java still have methods named using the original java convention (camelCase).
> 4- Some namespaces are stil in camelCase (example Qpid.Client.qms)
> At least for 2 we should decide what the convention will be so that code can be adapted and be consistent in this regard.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (QPID-312) Inconsistency in naming conventions

Posted by "Tomas Restrepo (JIRA)" <qp...@incubator.apache.org>.
     [ https://issues.apache.org/jira/browse/QPID-312?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Tomas Restrepo updated QPID-312:
--------------------------------

    Attachment: QPID-312.diff

Attached an initial patch to start addressing these issues:

- Renames some missing interfaces to add the I prefix
- Fixes a lot of the classes with methods in pascalCase
- Changes a number of get/set methods in interfaces for proper properties
- Converts a number of comments in classes still in javadoc style into proper C# XML comments

Most notably missing in the changes is most of the ByteBuffer related stuff, since changing it would break the spec generated code. 

> Inconsistency in naming conventions
> -----------------------------------
>
>                 Key: QPID-312
>                 URL: https://issues.apache.org/jira/browse/QPID-312
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Dot Net Client
>    Affects Versions: M2
>            Reporter: Tomas Restrepo
>            Priority: Trivial
>         Attachments: QPID-312.diff
>
>
> There is some inconsistency at this time naming conventions that would be good to resolve:
> 1- Some interfaces still have their original java-like name without the I prefix, which is the usual .NET convention. Examples: ByteBufferAllocator, BrokerInfo, ConnectionInfo
> 2- Some classes that use the Amq prefix while others most use AMQ (like AmqBrokerInfo and AmqChannel). The latter is the recommended convention by FxCop, but it doesn't matter much as long as we're consistent.
> 3- A lot of classes ported from Java still have methods named using the original java convention (camelCase).
> 4- Some namespaces are stil in camelCase (example Qpid.Client.qms)
> At least for 2 we should decide what the convention will be so that code can be adapted and be consistent in this regard.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.