You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@sling.apache.org by "Stefan Seifert (JIRA)" <ji...@apache.org> on 2013/10/16 10:19:42 UTC
[jira] [Commented] (SLING-3169) Job state and related enumerations
[ https://issues.apache.org/jira/browse/SLING-3169?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13796541#comment-13796541 ]
Stefan Seifert commented on SLING-3169:
---------------------------------------
good solution for the ResultBuilder interface.
concerning the JobState: you are right. i think the enum names/method names are not fully intuitive for ones that have used similar states in other systems but with different meanings. so for the JobState from the job endinge POV the states are fine (although it had used FAILED instead of CANCELLED, but this is only my personal preference, i'm fine with CANCELLED as well). but now its in synch with the old JobResult enum from the JobConsumer interface, so it's at least consistent now.
together with the javadocs the methods in the ResultBuilder method should be clear now.
> Job state and related enumerations
> ----------------------------------
>
> Key: SLING-3169
> URL: https://issues.apache.org/jira/browse/SLING-3169
> Project: Sling
> Issue Type: New Feature
> Components: Extensions
> Reporter: Carsten Ziegeler
> Assignee: Carsten Ziegeler
> Fix For: Extensions Event 3.3.0
>
>
> This is a follow up from SLING-3028 based on comments by Stefan Seifert:
> I find the enum name Job.JobType not ideal, because it does not stand of a type but for a state of the job. But there is a JobState enum in the consumer API package already.
> I find the enum and class names JobState and JobStatus in the consumer package not ideal, because they do not stand for a state, but for a job result.
>
--
This message was sent by Atlassian JIRA
(v6.1#6144)