You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Konstantin Shvachko (JIRA)" <ji...@apache.org> on 2010/12/01 01:31:11 UTC
[jira] Created: (HDFS-1522) Merge Block.BLOCK_FILE_PREFIX and
DataStorage.BLOCK_FILE_PREFIX into one contant
Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one contant
--------------------------------------------------------------------------------
Key: HDFS-1522
URL: https://issues.apache.org/jira/browse/HDFS-1522
Project: Hadoop HDFS
Issue Type: Bug
Components: data-node
Affects Versions: 0.21.0
Reporter: Konstantin Shvachko
Fix For: 0.22.0
Two semantically identical constant {{Block.BLOCK_FILE_PREFIX}} and {{DataStorage.BLOCK_FILE_PREFIX}} should merged into one. Should be defined in {{Block}}, imo.
Also use cases of "blok_", like in {{DirectoryScanner}} should be replaced by the this constant.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (HDFS-1522) Merge Block.BLOCK_FILE_PREFIX and
DataStorage.BLOCK_FILE_PREFIX into one constant
Posted by "Konstantin Shvachko (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/HDFS-1522?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Konstantin Shvachko updated HDFS-1522:
--------------------------------------
Summary: Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant (was: Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one contant)
> Merge Block.BLOCK_FILE_PREFIX and DataStorage.BLOCK_FILE_PREFIX into one constant
> ---------------------------------------------------------------------------------
>
> Key: HDFS-1522
> URL: https://issues.apache.org/jira/browse/HDFS-1522
> Project: Hadoop HDFS
> Issue Type: Bug
> Components: data-node
> Affects Versions: 0.21.0
> Reporter: Konstantin Shvachko
> Fix For: 0.22.0
>
>
> Two semantically identical constant {{Block.BLOCK_FILE_PREFIX}} and {{DataStorage.BLOCK_FILE_PREFIX}} should merged into one. Should be defined in {{Block}}, imo.
> Also use cases of "blok_", like in {{DirectoryScanner}} should be replaced by the this constant.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.