You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@oodt.apache.org by "Brian Foster (JIRA)" <ji...@apache.org> on 2012/06/20 02:48:42 UTC
[jira] [Created] (OODT-467) Change SciPgeConfigFileWriter to
DynamicConfigFileWriter
Brian Foster created OODT-467:
---------------------------------
Summary: Change SciPgeConfigFileWriter to DynamicConfigFileWriter
Key: OODT-467
URL: https://issues.apache.org/jira/browse/OODT-467
Project: OODT
Issue Type: Improvement
Components: pge wrapper framework
Affects Versions: 0.4
Environment: none
Reporter: Brian Foster
Assignee: Brian Foster
Priority: Minor
Fix For: 0.5
Attachments: OODT-467.2012-06-19.patch.txt
I figure this is a good time to change the name of this interface, which was poorly named, since cas-pge has taken a huge overhaulin... Logger is being added to the method arguments and the method name is being changed:
{code}
public File generateFile(String filePath, Metadata metadata, Logger logger,
Object... args) throws Exception;
{code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Updated] (OODT-467) Change SciPgeConfigFileWriter to
DynamicConfigFileWriter
Posted by "Brian Foster (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/OODT-467?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Brian Foster updated OODT-467:
------------------------------
Attachment: OODT-467.2012-06-19.patch.txt
- attached patch
> Change SciPgeConfigFileWriter to DynamicConfigFileWriter
> --------------------------------------------------------
>
> Key: OODT-467
> URL: https://issues.apache.org/jira/browse/OODT-467
> Project: OODT
> Issue Type: Improvement
> Components: pge wrapper framework
> Affects Versions: 0.4
> Environment: none
> Reporter: Brian Foster
> Assignee: Brian Foster
> Priority: Minor
> Fix For: 0.5
>
> Attachments: OODT-467.2012-06-19.patch.txt
>
>
> I figure this is a good time to change the name of this interface, which was poorly named, since cas-pge has taken a huge overhaulin... Logger is being added to the method arguments and the method name is being changed:
> {code}
> public File generateFile(String filePath, Metadata metadata, Logger logger,
> Object... args) throws Exception;
> {code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Updated] (OODT-467) Change SciPgeConfigFileWriter to
DynamicConfigFileWriter
Posted by "Brian Foster (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/OODT-467?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Brian Foster updated OODT-467:
------------------------------
Attachment: OODT-467.2012-06-19.patch.txt
> Change SciPgeConfigFileWriter to DynamicConfigFileWriter
> --------------------------------------------------------
>
> Key: OODT-467
> URL: https://issues.apache.org/jira/browse/OODT-467
> Project: OODT
> Issue Type: Improvement
> Components: pge wrapper framework
> Affects Versions: 0.4
> Environment: none
> Reporter: Brian Foster
> Assignee: Brian Foster
> Priority: Minor
> Fix For: 0.5
>
> Attachments: OODT-467.2012-06-19.patch.txt
>
>
> I figure this is a good time to change the name of this interface, which was poorly named, since cas-pge has taken a huge overhaulin... Logger is being added to the method arguments and the method name is being changed:
> {code}
> public File generateFile(String filePath, Metadata metadata, Logger logger,
> Object... args) throws Exception;
> {code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Updated] (OODT-467) Change SciPgeConfigFileWriter to
DynamicConfigFileWriter
Posted by "Brian Foster (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/OODT-467?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Brian Foster updated OODT-467:
------------------------------
Attachment: (was: OODT-467.2012-06-19.patch.txt)
> Change SciPgeConfigFileWriter to DynamicConfigFileWriter
> --------------------------------------------------------
>
> Key: OODT-467
> URL: https://issues.apache.org/jira/browse/OODT-467
> Project: OODT
> Issue Type: Improvement
> Components: pge wrapper framework
> Affects Versions: 0.4
> Environment: none
> Reporter: Brian Foster
> Assignee: Brian Foster
> Priority: Minor
> Fix For: 0.5
>
>
> I figure this is a good time to change the name of this interface, which was poorly named, since cas-pge has taken a huge overhaulin... Logger is being added to the method arguments and the method name is being changed:
> {code}
> public File generateFile(String filePath, Metadata metadata, Logger logger,
> Object... args) throws Exception;
> {code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
[jira] [Resolved] (OODT-467) Change SciPgeConfigFileWriter to
DynamicConfigFileWriter
Posted by "Brian Foster (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/OODT-467?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Brian Foster resolved OODT-467.
-------------------------------
Resolution: Fixed
- fixed in r1352684
> Change SciPgeConfigFileWriter to DynamicConfigFileWriter
> --------------------------------------------------------
>
> Key: OODT-467
> URL: https://issues.apache.org/jira/browse/OODT-467
> Project: OODT
> Issue Type: Improvement
> Components: pge wrapper framework
> Affects Versions: 0.4
> Environment: none
> Reporter: Brian Foster
> Assignee: Brian Foster
> Priority: Minor
> Fix For: 0.5
>
> Attachments: OODT-467.2012-06-19.patch.txt
>
>
> I figure this is a good time to change the name of this interface, which was poorly named, since cas-pge has taken a huge overhaulin... Logger is being added to the method arguments and the method name is being changed:
> {code}
> public File generateFile(String filePath, Metadata metadata, Logger logger,
> Object... args) throws Exception;
> {code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira