You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jackrabbit.apache.org by "angela (JIRA)" <ji...@apache.org> on 2007/10/31 15:49:50 UTC

[jira] Commented: (JCR-1200) allow SPI implementation to compute default values for autocreated properties

    [ https://issues.apache.org/jira/browse/JCR-1200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12539090 ] 

angela commented on JCR-1200:
-----------------------------

i think i would rather name it create(QPropertyDefinition) or createFromDefinition(QPropertyDefinition).

and i think i would return a QValue[].... since the prop def could be multi valued, couldn't it?

but i'm definitely in favor of this improvement.
angela




> allow SPI implementation to compute default values for autocreated properties
> -----------------------------------------------------------------------------
>
>                 Key: JCR-1200
>                 URL: https://issues.apache.org/jira/browse/JCR-1200
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: SPI
>            Reporter: Julian Reschke
>            Assignee: Julian Reschke
>            Priority: Minor
>
> Currently, when creating nodes in transient space, JCR2SPI uses hard-wired logic trying to populate system generated properties such as jcr:created, jcr;uuid and so on.
> This is problematic as
> - it doesn't scale -- it fails for autocreated properties not known to JCR2SPI, and
> - the syntax for the defaults may be dependant on the back end, such as legal syntax for (UU)IDs.
> Proposal:
> - extend QValueFactory with something like
>   QValue computeDefaultValue(QPropertyDefinition)
> - use that in JCR2SPI, getting rid of the currently hard-wired logic.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.