You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@fineract.apache.org by "abdelrahman (Jira)" <ji...@apache.org> on 2026/02/18 09:58:00 UTC

[jira] [Resolved] (FINERACT-2491) Refactor SavingsEnumerations to use switch expression instead of if-else chains

     [ https://issues.apache.org/jira/browse/FINERACT-2491?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

abdelrahman resolved FINERACT-2491.
-----------------------------------
    Resolution: Fixed

> Refactor SavingsEnumerations to use switch expression instead of if-else chains
> -------------------------------------------------------------------------------
>
>                 Key: FINERACT-2491
>                 URL: https://issues.apache.org/jira/browse/FINERACT-2491
>             Project: Apache Fineract
>          Issue Type: Improvement
>            Reporter: abdelrahman
>            Priority: Minor
>
> The SavingsEnumerations class currently uses chains of if-else statements in the savingEnumueration() method, which reduces code readability and maintainability. This refactoring replaces the if-else chain with a switch expression to improve readability and maintainability.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)