You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Tsz Wo Nicholas Sze (JIRA)" <ji...@apache.org> on 2016/04/21 23:38:13 UTC
[jira] [Commented] (HDFS-10224) Implement asynchronous rename for
DistributedFileSystem
[ https://issues.apache.org/jira/browse/HDFS-10224?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15252796#comment-15252796 ]
Tsz Wo Nicholas Sze commented on HDFS-10224:
--------------------------------------------
Thanks for working on this. Some comments on the patch:
- Let's rename getMsgCallback() to getReturnMessageCallback(), getValueCallback() to getReturnValueCallback() and getFsStatistics() to getStatistics() .
- AsyncDistributedFileSystem and its public methods need javadoc.
- Please annotate AsyncDistributedFileSystem as @Unstable.
- VOID_INSTANCE is not needed. Just return null.
- Please remove the unused imports added by the patch.
> Implement asynchronous rename for DistributedFileSystem
> -------------------------------------------------------
>
> Key: HDFS-10224
> URL: https://issues.apache.org/jira/browse/HDFS-10224
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Components: fs
> Reporter: Xiaobing Zhou
> Assignee: Xiaobing Zhou
> Attachments: HDFS-10224-HDFS-9924.000.patch, HDFS-10224-HDFS-9924.001.patch, HDFS-10224-HDFS-9924.002.patch, HDFS-10224-HDFS-9924.003.patch, HDFS-10224-and-HADOOP-12909.000.patch
>
>
> This is proposed to implement an asynchronous DistributedFileSystem based on AsyncFileSystem APIs in HADOOP-12910. In addition, rename is implemented in this JIRA.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)