You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ofbiz.apache.org by "Jacques Le Roux (JIRA)" <ji...@apache.org> on 2009/11/19 12:03:39 UTC

[jira] Closed: (OFBIZ-3180) SagePay payment gateway integrated

     [ https://issues.apache.org/jira/browse/OFBIZ-3180?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jacques Le Roux closed OFBIZ-3180.
----------------------------------

       Resolution: Fixed
    Fix Version/s: SVN trunk

Thanks Abdullah,

Your (slightly modified) patch is in trunk at r882103  

Some small details I changed (else your code was very well done)

* We son't need to put such comment in labels files (else we will finish with plenty) :     <!-- labels for SagePay payment gateway -->
* you forgot the white spaces between if and ( ;)
* when possible, prefer enhanced for loops on iterators
* in general please follow our [Coding+Conventions|http://docs.ofbiz.org/display/OFBADMIN/Coding+Conventions]. Most of the time I use Ctrl+Shft+F in Eclipse for that (only on code snippets and with a larger line than default - 150 instead of 80- else it breaks all) but I kept yours in the snippet beginning by
{code}
if (vendorTxCode != null) { parameters.put("VendorTxCode", vendorTxCode); }
{code}
because it was much more easier to read
* I remove this code snippet (vars never read)
{code}
String avsCv2 = (String) paymentResult.get("avsCv2");
String addressResult = (String) paymentResult.get("addressResult");
String postCodeResult = (String) paymentResult.get("postCodeResult");
String cv2Result = (String) paymentResult.get("cv2Result");
{code}
* as you I always use authorised (because it's how it's written ion French) but it's actually authorized (thanks to Eclipse automatic language check)

> SagePay payment gateway integrated
> ----------------------------------
>
>                 Key: OFBIZ-3180
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-3180
>             Project: OFBiz
>          Issue Type: New Feature
>          Components: accounting
>            Reporter: Abdullah Shaikh
>            Assignee: Jacques Le Roux
>             Fix For: SVN trunk
>
>         Attachments: httpclient-4.0.jar, httpcore-4.0.1.jar, jcip-annotations-1.0.jar, OFBIZ-3180_SagePay payment gateway.patch
>
>
> SagePay payment gateway integrated. All the gateway parameters are configurable using the Payment gateway configuration, also the transaction types that are available in sagepay are configurable.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.