You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Jean-Marc Spaggiari (JIRA)" <ji...@apache.org> on 2012/11/02 20:31:12 UTC

[jira] [Created] (HBASE-7088) Duplicate code in RowCounter

Jean-Marc Spaggiari created HBASE-7088:
------------------------------------------

             Summary: Duplicate code in RowCounter
                 Key: HBASE-7088
                 URL: https://issues.apache.org/jira/browse/HBASE-7088
             Project: HBase
          Issue Type: Improvement
          Components: mapreduce
    Affects Versions: 0.94.2
            Reporter: Jean-Marc Spaggiari
            Assignee: Jean-Marc Spaggiari
            Priority: Minor


On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
    if (qualifiers.size() == 0) {
      scan.setFilter(new FirstKeyOnlyFilter());
    } else {
      scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
    }

Should the line 125 simply be removed?


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HBASE-7088) Duplicate code in RowCounter

Posted by "Jean-Marc Spaggiari (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jean-Marc Spaggiari updated HBASE-7088:
---------------------------------------

    Attachment: HBASE-7088.patch

Removal of a small duplicate code.
                
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>         Attachments: HBASE-7088.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (HBASE-7088) Duplicate code in RowCounter

Posted by "Hadoop QA (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489920#comment-13489920 ] 

Hadoop QA commented on HBASE-7088:
----------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12551959/HBASE-7088.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 hadoop2.0{color}.  The patch compiles against the hadoop 2.0 profile.

    {color:red}-1 javadoc{color}.  The javadoc tool appears to have generated 85 warning messages.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of javac compiler warnings.

    {color:red}-1 findbugs{color}.  The patch appears to introduce 4 new Findbugs (version 1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in .

Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/3216//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3216//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop2-compat.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3216//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3216//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3216//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/3216//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/3216//console

This message is automatically generated.
                
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>         Attachments: HBASE-7088.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
> {code}
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> {code}
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (HBASE-7088) Duplicate code in RowCounter

Posted by "Ted Yu (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489905#comment-13489905 ] 

Ted Yu commented on HBASE-7088:
-------------------------------

+1 on patch.
                
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>         Attachments: HBASE-7088.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
> {code}
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> {code}
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HBASE-7088) Duplicate code in RowCounter

Posted by "Jean-Marc Spaggiari (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jean-Marc Spaggiari updated HBASE-7088:
---------------------------------------

    Description: 
On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
{code}
    if (qualifiers.size() == 0) {
      scan.setFilter(new FirstKeyOnlyFilter());
    } else {
      scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
    }
{/code}
Should the line 125 simply be removed?


  was:
On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
    if (qualifiers.size() == 0) {
      scan.setFilter(new FirstKeyOnlyFilter());
    } else {
      scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
    }

Should the line 125 simply be removed?


    
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>         Attachments: HBASE-7088.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
> {code}
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> {/code}
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (HBASE-7088) Duplicate code in RowCounter

Posted by "Elliott Clark (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489769#comment-13489769 ] 

Elliott Clark commented on HBASE-7088:
--------------------------------------

Seems reasonable to me.  Do you want to throw up a patch ?
                
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HBASE-7088) Duplicate code in RowCounter

Posted by "Jean-Marc Spaggiari (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jean-Marc Spaggiari updated HBASE-7088:
---------------------------------------

    Status: Patch Available  (was: Open)
    
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>         Attachments: HBASE-7088.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Commented] (HBASE-7088) Duplicate code in RowCounter

Posted by "Jean-Marc Spaggiari (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489803#comment-13489803 ] 

Jean-Marc Spaggiari commented on HBASE-7088:
--------------------------------------------

Sure I will. Will try tonight, else, this week-end.
                
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HBASE-7088) Duplicate code in RowCounter

Posted by "Jean-Marc Spaggiari (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jean-Marc Spaggiari updated HBASE-7088:
---------------------------------------

    Description: 
On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
{code}
    if (qualifiers.size() == 0) {
      scan.setFilter(new FirstKeyOnlyFilter());
    } else {
      scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
    }
{code}
Should the line 125 simply be removed?


  was:
On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
{code}
    if (qualifiers.size() == 0) {
      scan.setFilter(new FirstKeyOnlyFilter());
    } else {
      scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
    }
{/code}
Should the line 125 simply be removed?


    
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>         Attachments: HBASE-7088.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());" statement which is not required at line 125 since we have this on line 141:
> {code}
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> {code}
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira