You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tomcat.apache.org by Christopher Schultz <ch...@christopherschultz.net> on 2018/04/25 13:39:04 UTC
Improvements to Cipher.java
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
All,
I have a few proposals for o.a.t.u.net.openssl.ciphers.Ciphers.java:
1. Remove the isExport method. It is unused anywhere, and practically
already covered by other information about the ciphers (e.g.
"strength", the "EXPORT" alias, etc.).
2. Replace bare-boolean values in (calls to) Cipher constructor with
named constants e.g. FIPS_COMPATIBLE (true) and FIPS_INCOMPATIBLE
(false) for improved readability of the code. This should have zero
impact on the compiled .class file.
Side note: do we even need the "FIPS-compatible flag"? We don't use it
anywhere. When running in FIPS-mode, those crypto promitives that are
unsupported will simply be ignored by the crypto engine.
3. Remove "alg bits". It's not used anywhere and doesn't seem useful.
(Unless there was a future plan for it.)
Any objections?
Thanks,
- -chris
-----BEGIN PGP SIGNATURE-----
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
iQIzBAEBCAAdFiEEMmKgYcQvxMe7tcJcHPApP6U8pFgFAlrghPgACgkQHPApP6U8
pFi7Dg/9Hc1JrjuObgXdkwBPr5TNfSNTxCtJaNTyUqKLz97zdFMZ4R6qTNXXjLqL
+HaTagRQI5v6ieCdlSu5bFzaymzhixoMThzQgNhRv51GiJLxDk00DHpLamrMH2tc
TQR5P+3CF/OHnhJg14QCiunap8wJm0wKYkuo41oDbFWe+b/AEYZeZW8XzxFWyGlc
pAoiZf7T6ISqo6A7A+YZ/RvOqOt8oH3MbpArrbGYFsvNPzUCl2iHfl/vasEXVtTv
vxx090r3dn/cMB76Ed/vPKeKv9UeOeB3Z4NodyEDuJX5WLyyrHEa8HDq9AED7mD+
oMqERA12bstCz98MWpgjXe2Lk/NchzBylJfSb1ZWL9bi+svyXk0VKnxtrKQyDOC6
NVFQFbAIA+9uBKUJXMUFx/Rneo3Y9C0kVLAHH5CzO9vSgnCHllFI0FyvRoOh3JN0
GtFozjdfxUkwRWd6gjE7/3vXfGrmBIgPo79wA3mpUWGk/LKtnQMmbhPKV7NI46B8
FvZjzlVIHp0pVVSwbLDCbPRuZ2yZCPV6hii1wVB/WTbce9WNv530Sar2y36glEcU
+SqBR3gR5z0LMlBYzXI3iXvlMAcLdVpQUeviFt2QSzEZqTspjwZ2AC1O5Iyi4tX+
E/JUm22DXR/MxVW23bIVsdrHa4tXf4/mVejFkyaURsnAXExwm40=
=AWBy
-----END PGP SIGNATURE-----
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org
Re: Improvements to Cipher.java
Posted by Christopher Schultz <ch...@christopherschultz.net>.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
Mark,
On 4/25/18 10:08 AM, Mark Thomas wrote:
> On 25/04/18 14:39, Christopher Schultz wrote:
>
> <snip/>
>
>> Any objections?
>
> +1 to all the above.
>
> Note a lot of that is public API changes so we should really
> deprecate in 9.0.x and remove in 10.x.
ACK.
I don't see this class in 8.5.x, so I see no reason to consider
back-porting.
- -chris
-----BEGIN PGP SIGNATURE-----
Comment: GPGTools - http://gpgtools.org
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
iQIzBAEBCAAdFiEEMmKgYcQvxMe7tcJcHPApP6U8pFgFAlrgkLIACgkQHPApP6U8
pFgsfw//fC5XKaXpcvL/Em1DI0lqF/VEgqt1lH/6e9yjgJEcCLWQS4NqqcSlwoKb
X+ch+WzAqI1UHtP34obQvMWECzkIoFhnCCL7RL+1CJqL5Nt4gx9awrEbkrfDViom
Ic60PM0UihRC6IWx9lUHtFLBsIdCirD9se9YJEBSrl1k4aYczICZa09bxTR+FRqZ
ePJLArjsovot+pksLeKkCuXUhpj/StQGVafcKgScPKudbmFvUo90CA7fB4geWUCb
4D2xlhDOfs76pZ1entrgaSiZ/HxoE+lluftChBP0QJwE2Uq7sZJUwxbX4YlWETzH
YHmOHCahFkbitCONmuDiE984rdZEUIT1iGaa371k23C6NvfpqWXVDQ2ln7kAy1rQ
meeQoRS+CKOrYQzvtTh9GQKL9xcJM/46ojt2SiCEOtITx/NoMicHa1UzKD/V9pMh
nvsLVvcbVQ6kYwi8pTAcSUvoSUU+Px6jJ/vE9ZezuPOi18HgvG22NBzRuxuSKCMT
y8QiDDPXLFAr75WZnlBHyUEaigo/3NMUdJ92nHT+hVHwEMqHry53Je0I6FsTrQ9g
yRxyYPn3p+xgx/mN670SYNKBr/tnBG2OFkd5Qw3BCWD/CRWVfktW8+dJqm8UCYIv
upIuSWRQuojFWeWC2oTpwYEP1xdCDQ++Ok4ZTDeCtx+8pdYt7KE=
=7GgR
-----END PGP SIGNATURE-----
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org
Re: Improvements to Cipher.java
Posted by Mark Thomas <ma...@apache.org>.
On 25/04/18 14:39, Christopher Schultz wrote:
<snip/>
> Any objections?
+1 to all the above.
Note a lot of that is public API changes so we should really deprecate
in 9.0.x and remove in 10.x.
Mark
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org