You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@thrift.apache.org by "Martin Vogt (JIRA)" <ji...@apache.org> on 2014/06/19 14:19:25 UTC

[jira] [Updated] (THRIFT-2295) Make "oneway" more generic

     [ https://issues.apache.org/jira/browse/THRIFT-2295?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Martin Vogt updated THRIFT-2295:
--------------------------------

    Attachment: 040_functionModifiers140619v1.patch

Updated against current git. Although the old one still should work.

The patch works fine here, tested with C# (Linux,Win) 
and C++ additionally it adds nothing new, 
but cleans up the code a bit (IMHO)




> Make "oneway" more generic
> --------------------------
>
>                 Key: THRIFT-2295
>                 URL: https://issues.apache.org/jira/browse/THRIFT-2295
>             Project: Thrift
>          Issue Type: Improvement
>          Components: Compiler (General)
>    Affects Versions: 0.9.1
>            Reporter: Martin Vogt
>            Priority: Trivial
>         Attachments: 040_functionModifiers140619v1.patch, functionModifiers131227v1.patch
>
>
> I'm experimenting with different function modifiers 
> ("oneway","signal","slot", etc...)
> The current code does not make such tests easy, because the "oneway"
> modifier is hardcoded  as bool.
> The following patch improves the optional function modifier to be more generic.



--
This message was sent by Atlassian JIRA
(v6.2#6252)