You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@geode.apache.org by "Mark Hanson (JIRA)" <ji...@apache.org> on 2017/09/08 17:48:00 UTC

[jira] [Updated] (GEODE-3570) Overloading int for waiting and the like should be stopped and api broken out

     [ https://issues.apache.org/jira/browse/GEODE-3570?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Mark Hanson updated GEODE-3570:
-------------------------------
    Description: 
See discussion here http://markmail.org/thread/hwrkg5cra57lyvo3

Currently the code in the native client follows various conventions. We would like to standardize the code to use a model where instead of overloading int to mean infinity on a wait, to create two separate function calls. One for wait indefinitely wait()  and one to wait for a duration waitDuration(duration)

ThinClientRegion.cpp:2996 executeFunction needs refactoring.
PoolAttributes.hpp:69 setRetryAttempts needs to be retitled attempts and then the using functions need to use it appropriately.

  was:
See discussion here http://markmail.org/thread/hwrkg5cra57lyvo3

Currently the code in the native client follows various conventions. We would like to standardize the code to use a model where instead of overloading int to mean infinity on a wait, to create two separate function calls. One for wait indefinitely wait()  and one to wait for a duration waitDuration(duration)


> Overloading int for waiting and the like should be stopped and api broken out
> -----------------------------------------------------------------------------
>
>                 Key: GEODE-3570
>                 URL: https://issues.apache.org/jira/browse/GEODE-3570
>             Project: Geode
>          Issue Type: Improvement
>          Components: native client
>            Reporter: Mark Hanson
>
> See discussion here http://markmail.org/thread/hwrkg5cra57lyvo3
> Currently the code in the native client follows various conventions. We would like to standardize the code to use a model where instead of overloading int to mean infinity on a wait, to create two separate function calls. One for wait indefinitely wait()  and one to wait for a duration waitDuration(duration)
> ThinClientRegion.cpp:2996 executeFunction needs refactoring.
> PoolAttributes.hpp:69 setRetryAttempts needs to be retitled attempts and then the using functions need to use it appropriately.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)