You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Subramaniam Krishnan (JIRA)" <ji...@apache.org> on 2014/09/08 23:37:29 UTC

[jira] [Updated] (YARN-1709) Admission Control: Reservation subsystem

     [ https://issues.apache.org/jira/browse/YARN-1709?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Subramaniam Krishnan updated YARN-1709:
---------------------------------------
    Attachment: YARN-1709.patch

Thanks [~chris.douglas] for your exhaustive review. I am uploading a patch that has the following fixes:
  * Cloned _ZERO_RESOURCE_, _minimumAllocation_ and _maximumAllocation_ to prevent leaking of mutable data
   * Removed MessageFormat. Have to concat strings in few cases where they are both logged and included as part of exception message
  * Fixed the code readability and lock scope in _addReservation()_
  * Added assertions for _isWriteLockedByCurrentThread()_ in private methods that assume locks
  * Removed redundant _this_ in get methods
  * toString uses StringBuilder instead of StringBuffer now
  * Fixed Javadoc - content (_getEarliestStartTime()_) and whitespaces
  * Made _ReservationInterval_ immutable, good catch

The ReservationSystem uses UTCClock (added as part of YARN-1708) to enforce UTC times.  

> Admission Control: Reservation subsystem
> ----------------------------------------
>
>                 Key: YARN-1709
>                 URL: https://issues.apache.org/jira/browse/YARN-1709
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Carlo Curino
>            Assignee: Subramaniam Krishnan
>         Attachments: YARN-1709.patch, YARN-1709.patch, YARN-1709.patch, YARN-1709.patch
>
>
> This JIRA is about the key data structure used to track resources over time to enable YARN-1051. The Reservation subsystem is conceptually a "plan" of how the scheduler will allocate resources over-time.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)