You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Paulo Motta (JIRA)" <ji...@apache.org> on 2017/02/15 15:06:41 UTC
[jira] [Commented] (CASSANDRA-13081) Confusing
StreamReader.StreamDeserializer.cleanup leftover? code
[ https://issues.apache.org/jira/browse/CASSANDRA-13081?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15867977#comment-15867977 ]
Paulo Motta commented on CASSANDRA-13081:
-----------------------------------------
Mind reviewing [~slebresne]? This is a leftover from CASSANDRA-12716.
> Confusing StreamReader.StreamDeserializer.cleanup leftover? code
> ----------------------------------------------------------------
>
> Key: CASSANDRA-13081
> URL: https://issues.apache.org/jira/browse/CASSANDRA-13081
> Project: Cassandra
> Issue Type: Improvement
> Components: Core
> Reporter: Dave Brosius
> Assignee: Paulo Motta
> Priority: Trivial
> Fix For: 4.x
>
>
> The cleanup method in StreamReader.StreamDeserializer does stuff in the cases when the field 'in' is a RewindableDataInputStreamPlus typed object.
> Given that it is a
> this.in = new DataInputPlus.DataInputStreamPlus(in);
> that can never be. I'm assuming this was left over from some previous refactor or such. Assuming we can just delete this?
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)