You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Igor Sapego (Jira)" <ji...@apache.org> on 2024/06/27 11:08:00 UTC

[jira] [Commented] (IGNITE-22460) C++ 3.0: Re-name C++ libraries to prevent clash with Ignite 2

    [ https://issues.apache.org/jira/browse/IGNITE-22460?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17860433#comment-17860433 ] 

Igor Sapego commented on IGNITE-22460:
--------------------------------------

After discussion with [~dzabotlin] I've decided to only rename libignite-client.so to libignite3-client.so. ODBC library name is already different, tests naming is not important for users, and include paths changes can be too disruptive.

> C++ 3.0: Re-name C++ libraries to prevent clash with Ignite 2
> -------------------------------------------------------------
>
>                 Key: IGNITE-22460
>                 URL: https://issues.apache.org/jira/browse/IGNITE-22460
>             Project: Ignite
>          Issue Type: Improvement
>          Components: platforms
>            Reporter: Igor Sapego
>            Assignee: Igor Sapego
>            Priority: Major
>              Labels: ignite-3
>             Fix For: 3.0
>
>
> Make sure that client libraries follow the pattern ignite3... in Ignite 3



--
This message was sent by Atlassian Jira
(v8.20.10#820010)