You are viewing a plain text version of this content. The canonical link for it is here.
Posted to announce@apache.org by Carsten Ziegeler <cz...@apache.org> on 2025/02/10 05:52:36 UTC

FELIX-6751: CVE-2025-25247: Apache Felix Webconsole: XSS in services console

Severity: moderate

Affected versions:

- Apache Felix Webconsole Version 4.x through 4.9.8
- Apache Felix Webconsole Version 5.x through 5.0.8

Description:

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole.

This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8.

Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.

Credit:

Viktor Mares (me@viktormares.com) (finder)

References:

https://felix.apache.org/
https://www.cve.org/CVERecord?id=CVE-2025-25247