You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Elek, Marton (JIRA)" <ji...@apache.org> on 2018/06/23 16:31:00 UTC

[jira] [Commented] (HDDS-192) Create new SCMCommand to request a replication of a container

    [ https://issues.apache.org/jira/browse/HDDS-192?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16521211#comment-16521211 ] 

Elek, Marton commented on HDDS-192:
-----------------------------------

Patch is uploaded. I used the 'ReplicateContainer' as the name because CopyContainer is already used in the datanodeprotocol (it could be used to download the segments of the closed containers)

> Create new SCMCommand to request a replication of a container
> -------------------------------------------------------------
>
>                 Key: HDDS-192
>                 URL: https://issues.apache.org/jira/browse/HDDS-192
>             Project: Hadoop Distributed Data Store
>          Issue Type: New Feature
>          Components: SCM
>            Reporter: Elek, Marton
>            Assignee: Elek, Marton
>            Priority: Major
>             Fix For: 0.2.1
>
>         Attachments: HDDS-192.001.patch
>
>
> ReplicationManager needs to request replication/copy of container or deletion of container. We have DeleteContainerCommand (a command which is part of the datanode heartbeat response) but no command to request a copy of a container.
> This patch adds the command with all the required protobuf serialization/deserialization boilerplate to make it easier to review further patches. 
> No business logic in this patch, but there is a unit test which checks if the message is arrived to the datanode site from the scm side.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org