You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Ji Liu (JIRA)" <ji...@apache.org> on 2019/07/08 12:45:00 UTC
[jira] [Commented] (FLINK-13147) Duplicated code in 'if'
conditional statement
[ https://issues.apache.org/jira/browse/FLINK-13147?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16880277#comment-16880277 ]
Ji Liu commented on FLINK-13147:
--------------------------------
[~q977734161] Thanks for reporting this issue, I provided a PR to fix it.
> Duplicated code in 'if' conditional statement
> ----------------------------------------------
>
> Key: FLINK-13147
> URL: https://issues.apache.org/jira/browse/FLINK-13147
> Project: Flink
> Issue Type: Bug
> Components: Connectors / Hive
> Affects Versions: 1.6.3, 1.6.4, 1.7.2, 1.8.0, 1.8.1
> Reporter: lixiaobao
> Assignee: Ji Liu
> Priority: Minor
> Labels: pull-request-available
> Fix For: 1.7.3, 1.9.0
>
> Time Spent: 10m
> Remaining Estimate: 0h
>
> {code:java}
> } else if (type.equals(LogicalTypeRoot.VARBINARY)
> || type.equals(LogicalTypeRoot.BINARY)
> || type.equals(LogicalTypeRoot.BINARY)) {
> if (colStat instanceof CatalogColumnStatisticsDataBinary) {
> CatalogColumnStatisticsDataBinary binaryColumnStatsData = (CatalogColumnStatisticsDataBinary) colStat;
> BinaryColumnStatsData binaryColumnStats = new BinaryColumnStatsData(binaryColumnStatsData.getMaxLength(), binaryColumnStatsData.getAvgLength(), binaryColumnStatsData.getNullCount());
> return ColumnStatisticsData.binaryStats(binaryColumnStats);
> }{code}
> The class HiveStatsUtil have duplicated code in 'if' conditional statement.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)