You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@nuttx.apache.org by gu...@apache.org on 2021/09/18 10:33:55 UTC
[incubator-nuttx] 03/05: arch/riscv: Rename riscv_puts to up_puts
This is an automated email from the ASF dual-hosted git repository.
gustavonihei pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/incubator-nuttx.git
commit 71c61b11d9264eb165b772e4a5a291d0f70f8c75
Author: Xiang Xiao <xi...@xiaomi.com>
AuthorDate: Fri Sep 17 18:24:33 2021 +0800
arch/riscv: Rename riscv_puts to up_puts
since it's a common API defined in include/nuttx/arch.h
Signed-off-by: Xiang Xiao <xi...@xiaomi.com>
---
arch/risc-v/src/common/riscv_internal.h | 1 -
arch/risc-v/src/common/riscv_puts.c | 4 ++--
2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/arch/risc-v/src/common/riscv_internal.h b/arch/risc-v/src/common/riscv_internal.h
index c11cfcc..00520e1 100644
--- a/arch/risc-v/src/common/riscv_internal.h
+++ b/arch/risc-v/src/common/riscv_internal.h
@@ -200,7 +200,6 @@ void riscv_pminitialize(void);
/* Low level serial output **************************************************/
void riscv_lowputc(char ch);
-void riscv_puts(const char *str);
void riscv_lowputs(const char *str);
#ifdef USE_SERIALDRIVER
diff --git a/arch/risc-v/src/common/riscv_puts.c b/arch/risc-v/src/common/riscv_puts.c
index 8496a1d..788b8f9 100644
--- a/arch/risc-v/src/common/riscv_puts.c
+++ b/arch/risc-v/src/common/riscv_puts.c
@@ -32,14 +32,14 @@
****************************************************************************/
/****************************************************************************
- * Name: riscv_puts
+ * Name: up_puts
*
* Description:
* This is a low-level helper function used to support debug.
*
****************************************************************************/
-void riscv_puts(const char *str)
+void up_puts(const char *str)
{
while (*str)
{