You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Andrew Or (JIRA)" <ji...@apache.org> on 2015/07/23 01:05:06 UTC

[jira] [Updated] (SPARK-9267) Remove highly unnecessary accumulators stringify methods

     [ https://issues.apache.org/jira/browse/SPARK-9267?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Andrew Or updated SPARK-9267:
-----------------------------
    Description: 
{code}
def stringifyPartialValue(partialValue: Any): String = "%s".format(partialValue)
def stringifyValue(value: Any): String = "%s".format(value)
{code}
These are only used in 1 place. The level of indirection actually makes the code harder to read without an editor.

  was:
{code}
def stringifyPartialValue(partialValue: Any): String = "%s".format(partialValue)
def stringifyValue(value: Any): String = "%s".format(value)
{code}


> Remove highly unnecessary accumulators stringify methods
> --------------------------------------------------------
>
>                 Key: SPARK-9267
>                 URL: https://issues.apache.org/jira/browse/SPARK-9267
>             Project: Spark
>          Issue Type: Bug
>          Components: Spark Core
>    Affects Versions: 1.0.0
>            Reporter: Andrew Or
>            Assignee: Andrew Or
>            Priority: Trivial
>
> {code}
> def stringifyPartialValue(partialValue: Any): String = "%s".format(partialValue)
> def stringifyValue(value: Any): String = "%s".format(value)
> {code}
> These are only used in 1 place. The level of indirection actually makes the code harder to read without an editor.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org