You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by David Glasser <gl...@davidglasser.net> on 2007/09/19 18:26:20 UTC

naming issue: SVN_FS_PROP_TXN_*

Three property names are defined in libsvn_fs/fs-loader.h starting
with SVN_FS_PROP_TXN_: SVN_FS_PROP_TXN_CHECK_LOCKS,
SVN_FS_PROP_TXN_CHECK_OOD, and SVN_FS_PROP_TXN_CONTAINS_MERGEINFO.

Shouldn't they be SVN_FS__PROP_TXN_*?

(Also, I don't think contains-mergeinfo is necessary: it's only used
by FSFS, and you should be able to just see if the mergeinfo file
exists on disk instead, no?)

--dave

-- 
David Glasser | glasser@davidglasser.net | http://www.davidglasser.net/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: naming issue: SVN_FS_PROP_TXN_*

Posted by David Glasser <gl...@davidglasser.net>.
On 9/19/07, David Glasser <gl...@davidglasser.net> wrote:
> On 9/19/07, Malcolm Rowe <ma...@farside.org.uk> wrote:
> > On Wed, Sep 19, 2007 at 11:26:20AM -0700, David Glasser wrote:
> > > Three property names are defined in libsvn_fs/fs-loader.h starting
> > > with SVN_FS_PROP_TXN_: SVN_FS_PROP_TXN_CHECK_LOCKS,
> > > SVN_FS_PROP_TXN_CHECK_OOD, and SVN_FS_PROP_TXN_CONTAINS_MERGEINFO.
> > >
> > > Shouldn't they be SVN_FS__PROP_TXN_*?
> > >
> >
> > No, I think the first two are part of a public API, though I haven't
> > time to check just now.
>
> But they're defined in libsvn_fs/fs-loader.h...  There's
> SVN_FS_TXN_CHECK_OOD and SVN_FS_TXN_CHECK_LOCKS in svn_fs.h but that
> is different (bits instead of prop names).

Made this change in r27022.

> > > (Also, I don't think contains-mergeinfo is necessary: it's only used
> >
> > (agreed).
> >
> > > by FSFS, and you should be able to just see if the mergeinfo file
> > > exists on disk instead, no?)
> > >
> >
> > Sure.  I'd actually like to move the mergeinfo information -- currently
> > stored in a 'mergeinfo transaction property' file -- into the
> > already-existing transaction properties hash (since I see no reason why
> > we need a separate file).  So we'd need to read that instead, but sure.
>
> I guess arguably there's some efficiency argument being made that you
> only have to read and dump the mergeinfo each time a path is added
> during the transaction build phase, instead of the whole txnprops hash
> (log message, etc).  Of course the hash build is already quadratic...

Still considering this.

--dave

-- 
David Glasser | glasser@davidglasser.net | http://www.davidglasser.net/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: naming issue: SVN_FS_PROP_TXN_*

Posted by David Glasser <gl...@davidglasser.net>.
On 9/19/07, Malcolm Rowe <ma...@farside.org.uk> wrote:
> On Wed, Sep 19, 2007 at 11:26:20AM -0700, David Glasser wrote:
> > Three property names are defined in libsvn_fs/fs-loader.h starting
> > with SVN_FS_PROP_TXN_: SVN_FS_PROP_TXN_CHECK_LOCKS,
> > SVN_FS_PROP_TXN_CHECK_OOD, and SVN_FS_PROP_TXN_CONTAINS_MERGEINFO.
> >
> > Shouldn't they be SVN_FS__PROP_TXN_*?
> >
>
> No, I think the first two are part of a public API, though I haven't
> time to check just now.

But they're defined in libsvn_fs/fs-loader.h...  There's
SVN_FS_TXN_CHECK_OOD and SVN_FS_TXN_CHECK_LOCKS in svn_fs.h but that
is different (bits instead of prop names).

> > (Also, I don't think contains-mergeinfo is necessary: it's only used
>
> (agreed).
>
> > by FSFS, and you should be able to just see if the mergeinfo file
> > exists on disk instead, no?)
> >
>
> Sure.  I'd actually like to move the mergeinfo information -- currently
> stored in a 'mergeinfo transaction property' file -- into the
> already-existing transaction properties hash (since I see no reason why
> we need a separate file).  So we'd need to read that instead, but sure.

I guess arguably there's some efficiency argument being made that you
only have to read and dump the mergeinfo each time a path is added
during the transaction build phase, instead of the whole txnprops hash
(log message, etc).  Of course the hash build is already quadratic...

--dave

-- 
David Glasser | glasser@davidglasser.net | http://www.davidglasser.net/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: naming issue: SVN_FS_PROP_TXN_*

Posted by Malcolm Rowe <ma...@farside.org.uk>.
On Wed, Sep 19, 2007 at 11:26:20AM -0700, David Glasser wrote:
> Three property names are defined in libsvn_fs/fs-loader.h starting
> with SVN_FS_PROP_TXN_: SVN_FS_PROP_TXN_CHECK_LOCKS,
> SVN_FS_PROP_TXN_CHECK_OOD, and SVN_FS_PROP_TXN_CONTAINS_MERGEINFO.
> 
> Shouldn't they be SVN_FS__PROP_TXN_*?
> 

No, I think the first two are part of a public API, though I haven't
time to check just now.

> (Also, I don't think contains-mergeinfo is necessary: it's only used

(agreed).

> by FSFS, and you should be able to just see if the mergeinfo file
> exists on disk instead, no?)
> 

Sure.  I'd actually like to move the mergeinfo information -- currently
stored in a 'mergeinfo transaction property' file -- into the
already-existing transaction properties hash (since I see no reason why
we need a separate file).  So we'd need to read that instead, but sure.

Regards,
Malcolm