You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@rave.apache.org by Jasha Joachimsthal <j....@onehippo.com> on 2011/09/12 10:06:22 UTC

BasicEntity#getId() is incompatible with some Shindig interfaces

A few interfaces in the package org.apache.shindig.social.opensocial.model
(e.g. Activity) define a String getId(); Our BasicEntity defines a Long
getId();
This means that if we're going to rewrite the current implementations to use
the BasicEntity we have a conflict. This can either be solved to rename
BasicEntity#getId or change its return type into java.lang.Object. Any
suggestions?

Jasha Joachimsthal

Europe - Amsterdam - Oosteinde 11, 1017 WT Amsterdam - +31(0)20 522 4466
US - Boston - 1 Broadway, Cambridge, MA 02142 - +1 877 414 4776 (toll free)

www.onehippo.com

RE: BasicEntity#getId() is incompatible with some Shindig interfaces

Posted by "Ciancetta, Jesse E." <jc...@mitre.org>.
>A few interfaces in the package org.apache.shindig.social.opensocial.model
>(e.g. Activity) define a String getId(); Our BasicEntity defines a Long
>getId();
>This means that if we're going to rewrite the current implementations to use
>the BasicEntity we have a conflict. This can either be solved to rename
>BasicEntity#getId or change its return type into java.lang.Object. Any
>suggestions?

I'd vote to change the name of the BasicEntity#getId -- maybe to BasicEntity#getEntityId.

>Jasha Joachimsthal
>
>Europe - Amsterdam - Oosteinde 11, 1017 WT Amsterdam - +31(0)20 522 4466
>US - Boston - 1 Broadway, Cambridge, MA 02142 - +1 877 414 4776 (toll free)
>
>www.onehippo.com

RE: BasicEntity#getId() is incompatible with some Shindig interfaces

Posted by "Carlucci, Tony" <ac...@mitre.org>.
-----Original Message-----
From: Ciancetta, Jesse E. [mailto:jcian@mitre.org] 
Sent: Tuesday, September 13, 2011 8:34 AM
To: rave-dev@incubator.apache.org
Subject: RE: BasicEntity#getId() is incompatible with some Shindig interfaces

>A few interfaces in the package org.apache.shindig.social.opensocial.model
>(e.g. Activity) define a String getId(); Our BasicEntity defines a Long
>getId();
>This means that if we're going to rewrite the current implementations to use
>the BasicEntity we have a conflict. This can either be solved to rename
>BasicEntity#getId or change its return type into java.lang.Object. Any
>suggestions?

I'd vote to change the name of the BasicEntity#getId -- maybe to BasicEntity#getEntityId.

+1 for getEntityId

>Jasha Joachimsthal
>
>Europe - Amsterdam - Oosteinde 11, 1017 WT Amsterdam - +31(0)20 522 4466
>US - Boston - 1 Broadway, Cambridge, MA 02142 - +1 877 414 4776 (toll free)
>
>www.onehippo.com


---
Anthony Carlucci | SW App Dev Eng, Sr. | R501 / KW App Development & Maint
e: acarlucci@mitre.org | v: 781.271.2432 | f: 781.271.3299
The MITRE Corporation | 202 Burlington Rd | Bedford, MA 01730-1420

Re: BasicEntity#getId() is incompatible with some Shindig interfaces

Posted by Jasha Joachimsthal <j....@onehippo.com>.
Done. I didn't find any errors while testing. If you find any issues, please
report them in RAVE-260.

If you have an existing persistent databases, migrate the id column of
nearly each table to entity_id


On 15 September 2011 15:24, Jasha Joachimsthal
<j....@onehippo.com>wrote:

> I'll start refactoring getId to getEntityId (see
> https://issues.apache.org/jira/browse/RAVE-260).
>
> Jasha Joachimsthal
>
> Europe - Amsterdam - Oosteinde 11, 1017 WT Amsterdam - +31(0)20 522 4466
> US - Boston - 1 Broadway, Cambridge, MA 02142 - +1 877 414 4776 (toll
> free)
>
> www.onehippo.com
>
>
> On 14 September 2011 15:17, Franklin, Matthew B. <mf...@mitre.org>wrote:
>
>>
>>
>> >-----Original Message-----
>> >From: Carlucci, Tony [mailto:acarlucci@mitre.org]
>> >Sent: Tuesday, September 13, 2011 9:28 AM
>> >To: rave-dev@incubator.apache.org
>> >Subject: RE: BasicEntity#getId() is incompatible with some Shindig
>> interfaces
>> >
>> >-----Original Message-----
>> >From: Ciancetta, Jesse E. [mailto:jcian@mitre.org]
>> >Sent: Tuesday, September 13, 2011 8:34 AM
>> >To: rave-dev@incubator.apache.org
>> >Subject: RE: BasicEntity#getId() is incompatible with some Shindig
>> interfaces
>> >
>> >>A few interfaces in the package
>> org.apache.shindig.social.opensocial.model
>> >>(e.g. Activity) define a String getId(); Our BasicEntity defines a Long
>> >>getId();
>> >>This means that if we're going to rewrite the current implementations to
>> use
>> >>the BasicEntity we have a conflict. This can either be solved to rename
>> >>BasicEntity#getId or change its return type into java.lang.Object. Any
>> >>suggestions?
>> >
>> >I'd vote to change the name of the BasicEntity#getId -- maybe to
>> >BasicEntity#getEntityId.
>> >
>> >+1 for getEntityId
>>
>> +1
>>
>> >
>> >>Jasha Joachimsthal
>> >>
>> >>Europe - Amsterdam - Oosteinde 11, 1017 WT Amsterdam - +31(0)20 522
>> >4466
>> >>US - Boston - 1 Broadway, Cambridge, MA 02142 - +1 877 414 4776 (toll
>> free)
>> >>
>> >>www.onehippo.com
>> >
>> >
>> >---
>> >Anthony Carlucci | SW App Dev Eng, Sr. | R501 / KW App Development &
>> >Maint
>> >e: acarlucci@mitre.org | v: 781.271.2432 | f: 781.271.3299
>> >The MITRE Corporation | 202 Burlington Rd | Bedford, MA 01730-1420
>>
>>
>

Re: BasicEntity#getId() is incompatible with some Shindig interfaces

Posted by Jasha Joachimsthal <j....@onehippo.com>.
I'll start refactoring getId to getEntityId (see
https://issues.apache.org/jira/browse/RAVE-260).

Jasha Joachimsthal

Europe - Amsterdam - Oosteinde 11, 1017 WT Amsterdam - +31(0)20 522 4466
US - Boston - 1 Broadway, Cambridge, MA 02142 - +1 877 414 4776 (toll free)

www.onehippo.com


On 14 September 2011 15:17, Franklin, Matthew B. <mf...@mitre.org>wrote:

>
>
> >-----Original Message-----
> >From: Carlucci, Tony [mailto:acarlucci@mitre.org]
> >Sent: Tuesday, September 13, 2011 9:28 AM
> >To: rave-dev@incubator.apache.org
> >Subject: RE: BasicEntity#getId() is incompatible with some Shindig
> interfaces
> >
> >-----Original Message-----
> >From: Ciancetta, Jesse E. [mailto:jcian@mitre.org]
> >Sent: Tuesday, September 13, 2011 8:34 AM
> >To: rave-dev@incubator.apache.org
> >Subject: RE: BasicEntity#getId() is incompatible with some Shindig
> interfaces
> >
> >>A few interfaces in the package
> org.apache.shindig.social.opensocial.model
> >>(e.g. Activity) define a String getId(); Our BasicEntity defines a Long
> >>getId();
> >>This means that if we're going to rewrite the current implementations to
> use
> >>the BasicEntity we have a conflict. This can either be solved to rename
> >>BasicEntity#getId or change its return type into java.lang.Object. Any
> >>suggestions?
> >
> >I'd vote to change the name of the BasicEntity#getId -- maybe to
> >BasicEntity#getEntityId.
> >
> >+1 for getEntityId
>
> +1
>
> >
> >>Jasha Joachimsthal
> >>
> >>Europe - Amsterdam - Oosteinde 11, 1017 WT Amsterdam - +31(0)20 522
> >4466
> >>US - Boston - 1 Broadway, Cambridge, MA 02142 - +1 877 414 4776 (toll
> free)
> >>
> >>www.onehippo.com
> >
> >
> >---
> >Anthony Carlucci | SW App Dev Eng, Sr. | R501 / KW App Development &
> >Maint
> >e: acarlucci@mitre.org | v: 781.271.2432 | f: 781.271.3299
> >The MITRE Corporation | 202 Burlington Rd | Bedford, MA 01730-1420
>
>

RE: BasicEntity#getId() is incompatible with some Shindig interfaces

Posted by "Franklin, Matthew B." <mf...@mitre.org>.

>-----Original Message-----
>From: Carlucci, Tony [mailto:acarlucci@mitre.org]
>Sent: Tuesday, September 13, 2011 9:28 AM
>To: rave-dev@incubator.apache.org
>Subject: RE: BasicEntity#getId() is incompatible with some Shindig interfaces
>
>-----Original Message-----
>From: Ciancetta, Jesse E. [mailto:jcian@mitre.org]
>Sent: Tuesday, September 13, 2011 8:34 AM
>To: rave-dev@incubator.apache.org
>Subject: RE: BasicEntity#getId() is incompatible with some Shindig interfaces
>
>>A few interfaces in the package org.apache.shindig.social.opensocial.model
>>(e.g. Activity) define a String getId(); Our BasicEntity defines a Long
>>getId();
>>This means that if we're going to rewrite the current implementations to use
>>the BasicEntity we have a conflict. This can either be solved to rename
>>BasicEntity#getId or change its return type into java.lang.Object. Any
>>suggestions?
>
>I'd vote to change the name of the BasicEntity#getId -- maybe to
>BasicEntity#getEntityId.
>
>+1 for getEntityId

+1

>
>>Jasha Joachimsthal
>>
>>Europe - Amsterdam - Oosteinde 11, 1017 WT Amsterdam - +31(0)20 522
>4466
>>US - Boston - 1 Broadway, Cambridge, MA 02142 - +1 877 414 4776 (toll free)
>>
>>www.onehippo.com
>
>
>---
>Anthony Carlucci | SW App Dev Eng, Sr. | R501 / KW App Development &
>Maint
>e: acarlucci@mitre.org | v: 781.271.2432 | f: 781.271.3299
>The MITRE Corporation | 202 Burlington Rd | Bedford, MA 01730-1420