You are viewing a plain text version of this content. The canonical link for it is here.
Posted to mapreduce-issues@hadoop.apache.org by "Chris Trezzo (JIRA)" <ji...@apache.org> on 2016/07/08 21:28:11 UTC

[jira] [Updated] (MAPREDUCE-6365) Refactor JobResourceUploader#uploadFilesInternal

     [ https://issues.apache.org/jira/browse/MAPREDUCE-6365?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chris Trezzo updated MAPREDUCE-6365:
------------------------------------
    Attachment: MAPREDUCE-6365-trunk-v1.patch

v1 patch attached. /cc [~sjlee0]

This is a simple patch that does the following:
# Separates files, libjars, archives, jobjar uploading logic into separate methods instead of one big method. This will make the code more readable in the future, especially when adding shared cache support.
# Rename the JobResourceUploader#uploadFiles method to uploadResources. This more appropriately represents what the method does and avoids a redundant method name when creating the new upload methods.

> Refactor JobResourceUploader#uploadFilesInternal
> ------------------------------------------------
>
>                 Key: MAPREDUCE-6365
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-6365
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>            Reporter: Chris Trezzo
>            Assignee: Chris Trezzo
>            Priority: Minor
>         Attachments: MAPREDUCE-6365-trunk-v1.patch
>
>
> JobResourceUploader#uploadFilesInternal is a large method and there are similar pieces of code that could probably be pulled out into separate methods.  This refactor would improve readability of the code.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: mapreduce-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: mapreduce-issues-help@hadoop.apache.org