You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Varun Vasudev (JIRA)" <ji...@apache.org> on 2017/07/12 10:25:00 UTC

[jira] [Updated] (YARN-6033) Add support for sections in container-executor configuration file

     [ https://issues.apache.org/jira/browse/YARN-6033?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Varun Vasudev updated YARN-6033:
--------------------------------
    Attachment: YARN-6033.003.patch

Thanks for the reviews [~sunil.govind@gmail.com], [~leftnoteasy]!

bq. 1. one doubt. In trim_comment, strchr will get first occurrence of the comment character rt, so it ll be replaced with a '/0'. What if two comment chars are present in the start of line?

It shouldn't matter, we'll just skip the line.

{quote}
2.

    merge_sections((struct section *) existing_section, new_section, 1);

In existing section, will it have enough memory to hold new section?

{quote}

Good catch, fixed.

{quote}
3.

    struct section *new_section = read_section(conf_file);

In read_config, if below code returns null, we will still go and do realloc for increase sectionentry details.
{quote}

Yeah, it shouldn't matter because we'll exit the loop no?

{quote}
1) It's better to move

struct section executor_cfg = \{.size=0, .sectiondetails=NULL};

and

struct configuration CFG = \{.size=0, .sections=NULL};

From container-executor.c to configurations.c. And add getter/setter method to configuration.h. I think we should not couple life cycle of configuration and container-executor since we could add other modules beyond container-executor in the new design.
{quote}

I've avoided this for now. My thinking was that each module could just create it's own version of the configuration object and manage the life cycle of the object. What do you think?

{quote}
2) some rename suggestions:

    sectionentry: is it better to call kv_pair?
    sectiondetails: if you agree with above, how about rename it to kv_pairs?
{quote}

Fixed.

> Add support for sections in container-executor configuration file
> -----------------------------------------------------------------
>
>                 Key: YARN-6033
>                 URL: https://issues.apache.org/jira/browse/YARN-6033
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager
>            Reporter: Varun Vasudev
>            Assignee: Varun Vasudev
>         Attachments: YARN-6033.003.patch, YARN-6033-YARN-5673.001.patch, YARN-6033-YARN-5673.002.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org