You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Dmitriy Selivanov (JIRA)" <ji...@apache.org> on 2016/04/01 10:58:25 UTC

[jira] [Created] (SPARK-14325) some strange name conflicts in `group_by`

Dmitriy Selivanov created SPARK-14325:
-----------------------------------------

             Summary: some strange name conflicts in `group_by`
                 Key: SPARK-14325
                 URL: https://issues.apache.org/jira/browse/SPARK-14325
             Project: Spark
          Issue Type: Bug
          Components: SparkR
    Affects Versions: 1.6.1, 1.6.0
         Environment: sparkR 1.6.0
            Reporter: Dmitriy Selivanov


group_by strange behaviour when try to aggregate by column with name "x".

consider following example
```
df
# DataFrame[userId:bigint, type:string, j:int, x:int]
group_by(df$userId, df$type, df$j) %>% agg(x = "sum")
#Error in (function (classes, fdef, mtable)  : 
#  unable to find an inherited method for function ‘agg’ for signature ‘"character"’
```
after renaming x -> x2 works just file.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org