You are viewing a plain text version of this content. The canonical link for it is here.
Posted to java-dev@axis.apache.org by Eran Chinthaka <ch...@opensource.lk> on 2005/09/14 05:31:56 UTC

[Axis2] Context Hierarchy

Hi Devs,

Our Context hierarchy is as follows.

ConfigurationContext                   AxisConfiguration
            |                                                  |
ServiceGroupContext                  ServiceGroupDescription
            |                                                  |
ServiceContext                           ServiceGroupDescription
           |                                                   |
OperationContext                       ServiceDescription
          |
MessageContext                        


For consistancy and clarity, I'd like to propose to do a small name change.
    1. ConfigurationContext --> AxisContext
    2. AxisConfiguration --> AxisDescription

We do always have naming wars, hope this will not be another one :)

Comments ?

-- Chinthaka




Re: [Axis2] Context Hierarchy

Posted by Sanjiva Weerawarana <sa...@opensource.lk>.
On Tue, 2005-09-13 at 23:49 -0400, Glen Daniels wrote:
> 
> +1 to AxisContext (this was "EngineContext" originally).  For the 
> "description" hierarchy, I'll suggest another alternative which I've 
> been meaning to bring up for a while:
> 
> OperationDescription -> AxisOperation
> ServiceDescription -> AxisService
> ServiceGroupDescription -> ServiceGroup
> AxisConfiguration stays the same

I'd prefer to maintain a consistent pattern if we're going to change to
this:

ConfigurationContext		AxisConfiguration
ServiceGroupContext		AxisServiceGroup
ServiceContext			AxisService
OperationContext		AxisOperation
MessageContext

I actually prefer the names Eran proposed:

AxisContext			AxisDescription
ServiceGroupContext		ServiceGroupDescription
ServiceContext			ServiceDescription
OperationContext		OperationDescription
MessageContext

for the simple reason that they both the corresponding names at a given
level start the same way and end differently. I know, such a deeply
technical reason.

> Second, these 
> are the names (except of course ServiceGroup) that we agreed to at the 
> first F2F.

The change to *Description was voted on here IIRC .. may have been
during your sleep period then ;-). 

> Naming is really important. :)  It's worth hashing it out.

+1. I can live with either of the above, but hate having naming
inconsistencies.

Sanjiva.



Re: [Axis2] Context Hierarchy

Posted by Glen Daniels <gl...@thoughtcraft.com>.
Hi Chinthaka:

> ConfigurationContext                   AxisConfiguration
>            |                                                  |
> ServiceGroupContext                  ServiceGroupDescription
>            |                                                  |
> ServiceContext                           ServiceGroupDescription
>           |                                                   |
> OperationContext                       ServiceDescription
>          |
> MessageContext                       

Assuming you meant ServiceContext->ServiceDescription, 
OperationContext->OperationDescription, and MessageContext->??

> For consistancy and clarity, I'd like to propose to do a small name change.
>    1. ConfigurationContext --> AxisContext
>    2. AxisConfiguration --> AxisDescription

+1 to AxisContext (this was "EngineContext" originally).  For the 
"description" hierarchy, I'll suggest another alternative which I've 
been meaning to bring up for a while:

OperationDescription -> AxisOperation
ServiceDescription -> AxisService
ServiceGroupDescription -> ServiceGroup
AxisConfiguration stays the same

The reason for this is twofold - first, the "description" suffix isn't 
really necessary, and I think might be confusing with WSDL descriptions 
(yes, the classes relate to WSDL structure, but the whole reason we have 
our own classes which inherit from the WSDL ones is to add Axis-specific 
stuff that usually does NOT get reflected in the WSDL).  Second, these 
are the names (except of course ServiceGroup) that we agreed to at the 
first F2F.

The reason I didn't make it "AxisServiceGroup" is simply that 
ServiceGroup isn't going to be as frequently used a class name as 
"Operation" and "Service" might be.  I'd be OK with that too.

> We do always have naming wars, hope this will not be another one :)

Naming is really important. :)  It's worth hashing it out.

--Glen