You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Neil Conway <ne...@gmail.com> on 2017/03/29 19:41:38 UTC

Review Request 58038: Removed redundant call to `std::string::c_str()` in Mesos.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/58038/
-----------------------------------------------------------

Review request for mesos and Benjamin Bannier.


Repository: mesos


Description
-------

Spotted via clang-tidy.


Diffs
-----

  src/tests/containerizer/docker_volume_isolator_tests.cpp 13a1f131973d15225e100b04f8e24c1f9f4d8539 


Diff: https://reviews.apache.org/r/58038/diff/1/


Testing
-------

`make check`


Thanks,

Neil Conway


Re: Review Request 58038: Removed redundant call to `std::string::c_str()` in Mesos.

Posted by Benjamin Bannier <be...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/58038/#review170479
-----------------------------------------------------------



Could you add `readability-redundant-string-cstr` to the default `CHECKS` in `support/mesos-tidy.sh`?

I am not exactly sure what checks you used in other patches in this chain, could you update their summaries to mention them?

- Benjamin Bannier


On March 29, 2017, 9:41 p.m., Neil Conway wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/58038/
> -----------------------------------------------------------
> 
> (Updated March 29, 2017, 9:41 p.m.)
> 
> 
> Review request for mesos and Benjamin Bannier.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Spotted via clang-tidy.
> 
> 
> Diffs
> -----
> 
>   src/tests/containerizer/docker_volume_isolator_tests.cpp 13a1f131973d15225e100b04f8e24c1f9f4d8539 
> 
> 
> Diff: https://reviews.apache.org/r/58038/diff/1/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Neil Conway
> 
>


Re: Review Request 58038: Removed redundant call to `std::string::c_str()` in Mesos.

Posted by Benjamin Bannier <be...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/58038/#review170536
-----------------------------------------------------------


Ship it!




- Benjamin Bannier


On March 30, 2017, 3:15 a.m., Neil Conway wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/58038/
> -----------------------------------------------------------
> 
> (Updated March 30, 2017, 3:15 a.m.)
> 
> 
> Review request for mesos and Benjamin Bannier.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Spotted using the "readability-redundant-string-cstr" clang-tidy check.
> 
> 
> Diffs
> -----
> 
>   src/tests/containerizer/docker_volume_isolator_tests.cpp 13a1f131973d15225e100b04f8e24c1f9f4d8539 
> 
> 
> Diff: https://reviews.apache.org/r/58038/diff/2/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Neil Conway
> 
>


Re: Review Request 58038: Removed redundant call to `std::string::c_str()` in Mesos.

Posted by Neil Conway <ne...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/58038/
-----------------------------------------------------------

(Updated March 30, 2017, 1:15 a.m.)


Review request for mesos and Benjamin Bannier.


Repository: mesos


Description (updated)
-------

Spotted using the "readability-redundant-string-cstr" clang-tidy check.


Diffs (updated)
-----

  src/tests/containerizer/docker_volume_isolator_tests.cpp 13a1f131973d15225e100b04f8e24c1f9f4d8539 


Diff: https://reviews.apache.org/r/58038/diff/2/

Changes: https://reviews.apache.org/r/58038/diff/1-2/


Testing
-------

`make check`


Thanks,

Neil Conway