You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@tapestry.apache.org by "Igor Drobiazko (JIRA)" <ji...@apache.org> on 2009/01/14 22:16:59 UTC

[jira] Reopened: (TAP5-69) Add annotation, @Contribute, to allow service contributor methods to be arbitrary named

     [ https://issues.apache.org/jira/browse/TAP5-69?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Igor Drobiazko reopened TAP5-69:
--------------------------------


Reopened because fix is invalid

> Add annotation, @Contribute, to allow service contributor methods to be arbitrary named
> ---------------------------------------------------------------------------------------
>
>                 Key: TAP5-69
>                 URL: https://issues.apache.org/jira/browse/TAP5-69
>             Project: Tapestry 5
>          Issue Type: Improvement
>    Affects Versions: 5.0.15
>            Reporter: Kalin Krustev
>            Assignee: Igor Drobiazko
>             Fix For: 5.1.0.0
>
>
> Tapestry used to require this naming convention for configuring services:
> public static Foo buildFoo(...) {...}
> public static void contrubuteFoo(...) {...}
> Then it allowed the first convention to be simplified as:
> public static Foo build(...) {...}
> It would be nice for the "contribute..." methods to allow also simpler naming and use the type of the "configuration" parameter to determine the configured service, which will also have the same type of parameter.
> For example:
> in Tapestry 5.0.5 TapestryModule.java:
>     public ServletApplicationInitializer build(...,  List<ServletApplicationInitializerFilter> configuration, ... )
> in my AppModule.java Tapestry 5.0.5 requires this naming:
> public void contributeServletApplicationInitializer(OrderedConfiguration<ServletApplicationInitializerFilter> configuration)
> Perhaps it could be simplified as:
> public void contribute(OrderedConfiguration<ServletApplicationInitializerFilter> configuration)
> If it will not be simplified, it would be nice to make the documentation about Tapestry IoC Configurations more clear that
> the naming of the contribute methods is important, not the type of configuration parameter.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.