You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "alnzng (via GitHub)" <gi...@apache.org> on 2026/02/10 04:32:36 UTC
[I] [Tech Debt] [python] Remove setuptools<82 constraint after apache-flink upgrades to apache-beam>=2.66.0 [flink-agents]
alnzng opened a new issue, #529:
URL: https://github.com/apache/flink-agents/issues/529
### Search before asking
- [x] I searched in the [issues](https://github.com/apache/flink-agents/issues) and found nothing similar.
### Description
### Problem
`setuptools 82.0.0` (released Feb 8, 2026) removed `pkg_resources` module entirely. `apache-beam<2.66.0` still uses `pkg_resources` in its `setup.py` ([source](https://github.com/apache/beam/blob/v2.65.0/sdks/python/setup.py)), so building `apache-beam` from source fails with:
```
ModuleNotFoundError: No module named 'pkg_resources'
```
Currently all `apache-flink` depends on `apache-beam <= 2.61.0`, which is affected.
### Current Workaround
We added `setuptools<82` constraints in `pyproject.toml` to pin setuptools to a version
that still includes `pkg_resources`:
- `[build-system] requires`: `setuptools>=75.3,<82`
- `[project] dependencies`: `setuptools>=75.3,<82`
- `[tool.uv.extra-build-dependencies]`: `apache-beam = ["setuptools<82"]`
PR: https://github.com/apache/flink-agents/pull/526
### Long Term Solution
`apache-beam>=2.66.0` removed `pkg_resources` usage from `setup.py`([PR #35153](https://github.com/apache/beam/pull/35153)).
Once `apache-flink` upgrades its `apache-beam` dependency to `>=2.66.0`, we can remove all `setuptools<82` constraints.
### Are you willing to submit a PR?
- [ ] I'm willing to submit a PR!
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: issues-unsubscribe@flink.apache.org.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
Re: [I] [Tech Debt] [python] Remove setuptools<82 constraint after apache-flink upgrades to apache-beam>=2.66.0 [flink-agents]
Posted by "wenjin272 (via GitHub) via issues" <is...@flink.apache.org>.
wenjin272 commented on issue #529:
URL: https://github.com/apache/flink-agents/issues/529#issuecomment-6622245087
@HsbcJone Thanks for offering to help. The Beam upgrade is on Flink’s development branch, but Flink Agents still supports released Flink versions that require older Beam versions. Even Flink 2.3.0 requires `apache-beam>=2.54.0,<=2.61.0`, so the prerequisite is not yet met and we still need these constraints.
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: issues-unsubscribe@flink.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org
Re: [I] [Tech Debt] [python] Remove setuptools<82 constraint after apache-flink upgrades to apache-beam>=2.66.0 [flink-agents]
Posted by "HsbcJone (via GitHub) via issues" <is...@flink.apache.org>.
HsbcJone commented on issue #529:
URL: https://github.com/apache/flink-agents/issues/529#issuecomment-6622132570
Hi maintainers — I'd like to take this if it is still wanted.
Apache Flink's Python packaging now depends on `apache-beam>=2.69.0` (so `>=2.66.0`), and Beam's `setup.py` no longer references `pkg_resources` from 2.66 onward. That looks like the precondition in this issue is met, so Flink Agents could drop the `setuptools<82` pin / uv extra-build-dependency.
Plan: remove the `<82` upper bound from `python/pyproject.toml` (build-system + project deps + `[tool.uv.extra-build-dependencies]`), verify Python packaging/tests still pass, and keep the change dependency-only.
Per CONTRIBUTING, could a committer confirm this direction before I open the PR? Happy to proceed once there is committer support.
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: issues-unsubscribe@flink.apache.org
For queries about this service, please contact Infrastructure at:
users@infra.apache.org