You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@geode.apache.org by "Blake Bender (JIRA)" <ji...@apache.org> on 2019/05/21 20:22:00 UTC

[jira] [Resolved] (GEODE-6718) Refactor TcrConnection::sendRequestForChunkedResponse, derived class, and remove pass-through calls in TrcConnection and derived

     [ https://issues.apache.org/jira/browse/GEODE-6718?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Blake Bender resolved GEODE-6718.
---------------------------------
    Resolution: Fixed

> Refactor TcrConnection::sendRequestForChunkedResponse, derived class, and remove pass-through calls in TrcConnection and derived
> --------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: GEODE-6718
>                 URL: https://issues.apache.org/jira/browse/GEODE-6718
>             Project: Geode
>          Issue Type: Improvement
>          Components: native client
>            Reporter: Blake Bender
>            Priority: Major
>          Time Spent: 1.5h
>  Remaining Estimate: 0h
>
> This is a small thing we can do to make the code more readable and maintainable.  TcrEndpoint only has one derived class, TcrPoolEndPoint, and the method sendRequestForChunkedResponse in both is simply a pass-through to call TcrConnection::sendRequestForChunkedResponse.  None of the parameters to the TcrConnection call are unknown to calling code, so nothing at all is being abstracted by having these methods on Tcr*Endpoint.  Additionally, the base class is abstract, so the implementation in TcrEndpoint is unreachable code, and even though the method is virtual it is declared protected, so nothing outside Tcr*Endpoint could possibly care about it.  In short, the method is gratuitous and removing it will clarify the code.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)