You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@poi.apache.org by bu...@apache.org on 2015/09/21 22:49:13 UTC

[Bug 58439] New: [PATCH] Rename private FormulaShifter.adjustPtgDueToShiftMove to adjustPtgDueToSheetMove

https://bz.apache.org/bugzilla/show_bug.cgi?id=58439

            Bug ID: 58439
           Summary: [PATCH] Rename private
                    FormulaShifter.adjustPtgDueToShiftMove to
                    adjustPtgDueToSheetMove
           Product: POI
           Version: unspecified
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: SS Common
          Assignee: dev@poi.apache.org
          Reporter: javenoneal@gmail.com
            Blocks: 58348

Created attachment 33123
  --> https://bz.apache.org/bugzilla/attachment.cgi?id=33123&action=edit
rename adjustPtgDueToShiftMode to adjustPtgDueToSheetMove

In FormulaShifter.java, the private method adjustPtgDueToShiftMove adjusts the
sheet field of a Ref3DPtg after a sheet has been moved. This was added in
r1142219 as a fix for bug 48294.

To differentiate a sheet move from a row move, I think a more appropriate name
for this method is adjustPtgDueToSheetMove. This also aligns the name with the
public static createForSheetShift method.

Because this method is private, it shouldn't affect any other files or existing
code.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


[Bug 58439] [PATCH] Rename private FormulaShifter.adjustPtgDueToShiftMove to adjustPtgDueToSheetMove

Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=58439

Dominik Stadler <do...@gmx.at> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|normal                      |enhancement

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


[Bug 58439] [PATCH] Rename private FormulaShifter.adjustPtgDueToShiftMove to adjustPtgDueToSheetMove

Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=58439

Javen ONeal <ja...@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |FIXED
             Status|NEW                         |RESOLVED

--- Comment #1 from Javen ONeal <ja...@gmail.com> ---
Implemented in r1710147
<https://svn.apache.org/viewvc?view=revision&revision=1710147>.

Deployed to trunk.

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org