You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Yang Jie (Jira)" <ji...@apache.org> on 2022/03/01 08:32:00 UTC

[jira] [Created] (SPARK-38360) Add a `exists` function for `TreeNode` to eliminate duplicate code pattern

Yang Jie created SPARK-38360:
--------------------------------

             Summary: Add a `exists` function for `TreeNode` to eliminate duplicate code pattern
                 Key: SPARK-38360
                 URL: https://issues.apache.org/jira/browse/SPARK-38360
             Project: Spark
          Issue Type: Improvement
          Components: SQL
    Affects Versions: 3.3.0
            Reporter: Yang Jie


There are many duplicate code patterns in the code:
{code:java}
treeNode.find(condition).isDefined 
treeNode.find(condition).nonEmpty 
treeNode.find(condition).isEmpty{code}
Maybe we can introduce an `exists` function to simplify the above code patterns.



--
This message was sent by Atlassian Jira
(v8.20.1#820001)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org