You are viewing a plain text version of this content. The canonical link for it is here.
Posted to c-dev@axis.apache.org by "b v j (JIRA)" <ji...@apache.org> on 2008/08/08 19:53:44 UTC

[jira] Created: (AXIS2C-1253) hello.c online example doc

hello.c online example doc
--------------------------

                 Key: AXIS2C-1253
                 URL: https://issues.apache.org/jira/browse/AXIS2C-1253
             Project: Axis2-C
          Issue Type: Task
         Environment: axis2c-bin-1.5.0-win32
            Reporter: b v j
            Priority: Trivial


The following excerpt was taken from the online hello.c example html:

http://ws.apache.org/axis2/c/docs/hello/client/hello.c.html


    client_home = AXIS2_GETENV("AXIS2C_HOME");
    if (!client_home && !strcmp(client_home, ""))
        client_home = "../..";


The test should be an OR statement instead of an AND statement. Not necessary, but also simplified by removing strcmp:


    client_home = AXIS2_GETENV("AXIS2C_HOME");
    if (!client_home || !(*client_home))
        client_home = "../..";



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-dev-help@ws.apache.org


[jira] Updated: (AXIS2C-1253) hello.c online example doc

Posted by "S.Uthaiyashankar (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AXIS2C-1253?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

S.Uthaiyashankar updated AXIS2C-1253:
-------------------------------------

      Component/s: documentation
    Fix Version/s: 1.6.0
         Assignee: S.Uthaiyashankar

> hello.c online example doc
> --------------------------
>
>                 Key: AXIS2C-1253
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-1253
>             Project: Axis2-C
>          Issue Type: Task
>          Components: documentation
>         Environment: axis2c-bin-1.5.0-win32
>            Reporter: b v j
>            Assignee: S.Uthaiyashankar
>            Priority: Trivial
>             Fix For: 1.6.0
>
>
> The following excerpt was taken from the online hello.c example html:
> http://ws.apache.org/axis2/c/docs/hello/client/hello.c.html
>     client_home = AXIS2_GETENV("AXIS2C_HOME");
>     if (!client_home && !strcmp(client_home, ""))
>         client_home = "../..";
> The test should be an OR statement instead of an AND statement. Not necessary, but also simplified by removing strcmp:
>     client_home = AXIS2_GETENV("AXIS2C_HOME");
>     if (!client_home || !(*client_home))
>         client_home = "../..";

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (AXIS2C-1253) hello.c online example doc

Posted by "S.Uthaiyashankar (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/AXIS2C-1253?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

S.Uthaiyashankar resolved AXIS2C-1253.
--------------------------------------

    Resolution: Fixed

Fixed in revision 728627. However, this will be reflected in the online file (http://ws.apache.org/axis2/c/docs/hello/client/hello.c.html) after next release.

> hello.c online example doc
> --------------------------
>
>                 Key: AXIS2C-1253
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-1253
>             Project: Axis2-C
>          Issue Type: Task
>          Components: documentation
>         Environment: axis2c-bin-1.5.0-win32
>            Reporter: b v j
>            Assignee: S.Uthaiyashankar
>            Priority: Trivial
>             Fix For: 1.6.0
>
>
> The following excerpt was taken from the online hello.c example html:
> http://ws.apache.org/axis2/c/docs/hello/client/hello.c.html
>     client_home = AXIS2_GETENV("AXIS2C_HOME");
>     if (!client_home && !strcmp(client_home, ""))
>         client_home = "../..";
> The test should be an OR statement instead of an AND statement. Not necessary, but also simplified by removing strcmp:
>     client_home = AXIS2_GETENV("AXIS2C_HOME");
>     if (!client_home || !(*client_home))
>         client_home = "../..";

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (AXIS2C-1253) hello.c online example doc

Posted by "S.Uthaiyashankar (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/AXIS2C-1253?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12658470#action_12658470 ] 

S.Uthaiyashankar commented on AXIS2C-1253:
------------------------------------------

I feel keeping strcmp is more readable. So leaving it as it is. Fixed AND to OR as specified above. 

> hello.c online example doc
> --------------------------
>
>                 Key: AXIS2C-1253
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-1253
>             Project: Axis2-C
>          Issue Type: Task
>          Components: documentation
>         Environment: axis2c-bin-1.5.0-win32
>            Reporter: b v j
>            Assignee: S.Uthaiyashankar
>            Priority: Trivial
>             Fix For: 1.6.0
>
>
> The following excerpt was taken from the online hello.c example html:
> http://ws.apache.org/axis2/c/docs/hello/client/hello.c.html
>     client_home = AXIS2_GETENV("AXIS2C_HOME");
>     if (!client_home && !strcmp(client_home, ""))
>         client_home = "../..";
> The test should be an OR statement instead of an AND statement. Not necessary, but also simplified by removing strcmp:
>     client_home = AXIS2_GETENV("AXIS2C_HOME");
>     if (!client_home || !(*client_home))
>         client_home = "../..";

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.