You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Aleksey Yeschenko (JIRA)" <ji...@apache.org> on 2015/03/03 04:11:04 UTC
[jira] [Commented] (CASSANDRA-8847) Improve MD5Digest.hashCode()
[ https://issues.apache.org/jira/browse/CASSANDRA-8847?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14344420#comment-14344420 ]
Aleksey Yeschenko commented on CASSANDRA-8847:
----------------------------------------------
+1. I'd rename 'h' to a more clear 'hashCode' though.
> Improve MD5Digest.hashCode()
> ----------------------------
>
> Key: CASSANDRA-8847
> URL: https://issues.apache.org/jira/browse/CASSANDRA-8847
> Project: Cassandra
> Issue Type: Improvement
> Components: Core
> Reporter: Robert Stupp
> Assignee: Robert Stupp
> Priority: Trivial
> Fix For: 2.1.4
>
> Attachments: md5digest.txt
>
>
> {{MD5Digest.hashCode}} always calculates the hash code when queried. Simple fix is to pre-calculate the hash code in the constructor.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)