You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@cloudstack.apache.org by Laszlo Hornyak <la...@gmail.com> on 2013/06/27 08:30:09 UTC

Re: Review Request 11980: FileUtil simplified

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/11980/
-----------------------------------------------------------

(Updated June 27, 2013, 6:30 a.m.)


Review request for cloudstack.


Changes
-------

added Assume to avoid failing the test on non-linux OS's


Repository: cloudstack-git


Description
-------

- writeToFile removed since no references to it
- readFileAsString replaced with FileUtils.readFileToString
- minor code duplication removed in dependent method getNicStats
- unit test added


Diffs (updated)
-----

  plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java b1bc99d 
  plugins/hypervisors/kvm/test/com/cloud/hypervisor/kvm/resource/LibvirtComputingResourceTest.java c82c31f 
  utils/src/com/cloud/utils/FileUtil.java 74f4088 

Diff: https://reviews.apache.org/r/11980/diff/


Testing
-------

test included


Thanks,

Laszlo Hornyak


Re: Review Request 11980: FileUtil simplified

Posted by edison su <ed...@citrix.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/11980/#review22474
-----------------------------------------------------------

Ship it!


Ship It!

- edison su


On June 27, 2013, 6:30 a.m., Laszlo Hornyak wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/11980/
> -----------------------------------------------------------
> 
> (Updated June 27, 2013, 6:30 a.m.)
> 
> 
> Review request for cloudstack.
> 
> 
> Repository: cloudstack-git
> 
> 
> Description
> -------
> 
> - writeToFile removed since no references to it
> - readFileAsString replaced with FileUtils.readFileToString
> - minor code duplication removed in dependent method getNicStats
> - unit test added
> 
> 
> Diffs
> -----
> 
>   plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java b1bc99d 
>   plugins/hypervisors/kvm/test/com/cloud/hypervisor/kvm/resource/LibvirtComputingResourceTest.java c82c31f 
>   utils/src/com/cloud/utils/FileUtil.java 74f4088 
> 
> Diff: https://reviews.apache.org/r/11980/diff/
> 
> 
> Testing
> -------
> 
> test included
> 
> 
> Thanks,
> 
> Laszlo Hornyak
> 
>


Re: Review Request 11980: FileUtil simplified

Posted by Prasanna Santhanam <ts...@apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/11980/#review22462
-----------------------------------------------------------


LGTM

- Prasanna Santhanam


On June 27, 2013, 6:30 a.m., Laszlo Hornyak wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/11980/
> -----------------------------------------------------------
> 
> (Updated June 27, 2013, 6:30 a.m.)
> 
> 
> Review request for cloudstack.
> 
> 
> Repository: cloudstack-git
> 
> 
> Description
> -------
> 
> - writeToFile removed since no references to it
> - readFileAsString replaced with FileUtils.readFileToString
> - minor code duplication removed in dependent method getNicStats
> - unit test added
> 
> 
> Diffs
> -----
> 
>   plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java b1bc99d 
>   plugins/hypervisors/kvm/test/com/cloud/hypervisor/kvm/resource/LibvirtComputingResourceTest.java c82c31f 
>   utils/src/com/cloud/utils/FileUtil.java 74f4088 
> 
> Diff: https://reviews.apache.org/r/11980/diff/
> 
> 
> Testing
> -------
> 
> test included
> 
> 
> Thanks,
> 
> Laszlo Hornyak
> 
>


Re: Review Request 11980: FileUtil simplified

Posted by Prasanna Santhanam <ts...@apache.org>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/11980/#review22495
-----------------------------------------------------------


882e5fa4e0c54ff53172b132c6184edadbc38b42

- Prasanna Santhanam


On June 27, 2013, 6:30 a.m., Laszlo Hornyak wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/11980/
> -----------------------------------------------------------
> 
> (Updated June 27, 2013, 6:30 a.m.)
> 
> 
> Review request for cloudstack.
> 
> 
> Repository: cloudstack-git
> 
> 
> Description
> -------
> 
> - writeToFile removed since no references to it
> - readFileAsString replaced with FileUtils.readFileToString
> - minor code duplication removed in dependent method getNicStats
> - unit test added
> 
> 
> Diffs
> -----
> 
>   plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java b1bc99d 
>   plugins/hypervisors/kvm/test/com/cloud/hypervisor/kvm/resource/LibvirtComputingResourceTest.java c82c31f 
>   utils/src/com/cloud/utils/FileUtil.java 74f4088 
> 
> Diff: https://reviews.apache.org/r/11980/diff/
> 
> 
> Testing
> -------
> 
> test included
> 
> 
> Thanks,
> 
> Laszlo Hornyak
> 
>