You are viewing a plain text version of this content. The canonical link for it is here.
Posted to cvs@httpd.apache.org by rj...@apache.org on 2011/11/12 01:12:50 UTC

svn commit: r1201111 - in /httpd/httpd/trunk/modules: aaa/config.m4 filters/config.m4 generators/config5.m4 mappers/config9.m4 metadata/config.m4

Author: rjung
Date: Sat Nov 12 00:12:50 2011
New Revision: 1201111

URL: http://svn.apache.org/viewvc?rev=1201111&view=rev
Log:
Change module sets and default activation status:

1) Promoted from "most" to "few"

- mod_headers

2) Demoted from "yes" to "most"

- mod_actions
- mod_allowmethods
- mod_auth_form
- mod_buffer
- mod_cgi(d)
- mod_include
- mod_negotiation
- mod_ratelimit
- mod_request
- mod_userdir

Remember: default module set is "most",
but only the LoadModule lines of all
modules except "yes" are commented out by default.

The following modules will now be loaded by default:

- mod_access_compat
- mod_alias
- mod_auth_basic
- mod_authn_core
- mod_authn_file
- mod_authz_core
- mod_authz_groupfile
- mod_authz_host
- mod_authz_user
- mod_autoindex
- mod_dir
- mod_env
- mod_filter
- mod_headers
- mod_log_config
- mod_mime
- mod_mpm_event
- mod_reqtimeout
- mod_setenvif
- mod_status
- mod_unixd
- mod_version

Modified:
    httpd/httpd/trunk/modules/aaa/config.m4
    httpd/httpd/trunk/modules/filters/config.m4
    httpd/httpd/trunk/modules/generators/config5.m4
    httpd/httpd/trunk/modules/mappers/config9.m4
    httpd/httpd/trunk/modules/metadata/config.m4

Modified: httpd/httpd/trunk/modules/aaa/config.m4
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/aaa/config.m4?rev=1201111&r1=1201110&r2=1201111&view=diff
==============================================================================
--- httpd/httpd/trunk/modules/aaa/config.m4 (original)
+++ httpd/httpd/trunk/modules/aaa/config.m4 Sat Nov 12 00:12:50 2011
@@ -63,7 +63,7 @@ APACHE_MODULE(access_compat, mod_access 
 dnl these are the front-end authentication modules
 
 APACHE_MODULE(auth_basic, basic authentication, , , yes)
-APACHE_MODULE(auth_form, form authentication, , , yes)
+APACHE_MODULE(auth_form, form authentication, , , most)
 APACHE_MODULE(auth_digest, RFC2617 Digest authentication, , , most, [
   APR_CHECK_APR_DEFINE(APR_HAS_RANDOM)
   if test $ac_cv_define_APR_HAS_RANDOM = "no"; then
@@ -73,7 +73,7 @@ APACHE_MODULE(auth_digest, RFC2617 Diges
   fi
 ])
 
-APACHE_MODULE(allowmethods, restrict allowed HTTP methods, , , yes)
+APACHE_MODULE(allowmethods, restrict allowed HTTP methods, , , most)
 
 APR_ADDTO(INCLUDES, [-I\$(top_srcdir)/$modpath_current])
 

Modified: httpd/httpd/trunk/modules/filters/config.m4
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/filters/config.m4?rev=1201111&r1=1201110&r2=1201111&view=diff
==============================================================================
--- httpd/httpd/trunk/modules/filters/config.m4 (original)
+++ httpd/httpd/trunk/modules/filters/config.m4 Sat Nov 12 00:12:50 2011
@@ -4,13 +4,13 @@ dnl APACHE_MODULE(name, helptext[, objec
 
 APACHE_MODPATH_INIT(filters)
 
-APACHE_MODULE(buffer, Filter Buffering, , , yes)
+APACHE_MODULE(buffer, Filter Buffering, , , most)
 APACHE_MODULE(data, RFC2397 data encoder, , , )
-APACHE_MODULE(ratelimit, Output Bandwidth Limiting, , , yes)
+APACHE_MODULE(ratelimit, Output Bandwidth Limiting, , , most)
 APACHE_MODULE(reqtimeout, Limit time waiting for request from client, , , yes)
 APACHE_MODULE(ext_filter, external filter module, , , most)
-APACHE_MODULE(request, Request Body Filtering, , , yes)
-APACHE_MODULE(include, Server Side Includes, , , yes)
+APACHE_MODULE(request, Request Body Filtering, , , most)
+APACHE_MODULE(include, Server Side Includes, , , most)
 APACHE_MODULE(filter, Smart Filtering, , , yes)
 APACHE_MODULE(reflector, Reflect request through the output filter stack, , , )
 APACHE_MODULE(substitute, response content rewrite-like filtering, , , most)

Modified: httpd/httpd/trunk/modules/generators/config5.m4
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/generators/config5.m4?rev=1201111&r1=1201110&r2=1201111&view=diff
==============================================================================
--- httpd/httpd/trunk/modules/generators/config5.m4 (original)
+++ httpd/httpd/trunk/modules/generators/config5.m4 Sat Nov 12 00:12:50 2011
@@ -32,7 +32,7 @@ case $host in
 esac
 
 if test $cgid_needed = "yes"; then
-    APACHE_MODULE(cgid, CGI scripts.  Enabled by default with threaded MPMs, , , yes, [
+    APACHE_MODULE(cgid, CGI scripts.  Enabled by default with threaded MPMs, , , most, [
     case $host in
       *-solaris2*)
         case `uname -r` in
@@ -72,7 +72,7 @@ For more info: <http://issues.apache.org
   ])
     APACHE_MODULE(cgi, CGI scripts.  Enabled by default with non-threaded MPMs, , , no)
 else
-    APACHE_MODULE(cgi, CGI scripts.  Enabled by default with non-threaded MPMs, , , yes)
+    APACHE_MODULE(cgi, CGI scripts.  Enabled by default with non-threaded MPMs, , , most)
     APACHE_MODULE(cgid, CGI scripts.  Enabled by default with threaded MPMs, , , no)
 fi
 

Modified: httpd/httpd/trunk/modules/mappers/config9.m4
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/mappers/config9.m4?rev=1201111&r1=1201110&r2=1201111&view=diff
==============================================================================
--- httpd/httpd/trunk/modules/mappers/config9.m4 (original)
+++ httpd/httpd/trunk/modules/mappers/config9.m4 Sat Nov 12 00:12:50 2011
@@ -5,12 +5,12 @@ dnl APACHE_MODULE(name, helptext[, objec
 APACHE_MODPATH_INIT(mappers)
 
 APACHE_MODULE(vhost_alias, mass virtual hosting module, , , most)
-APACHE_MODULE(negotiation, content negotiation, , , yes)
+APACHE_MODULE(negotiation, content negotiation, , , most)
 APACHE_MODULE(dir, directory request handling, , , yes)
 APACHE_MODULE(imagemap, server-side imagemaps, , , no)
-APACHE_MODULE(actions, Action triggering on requests, , , yes)
+APACHE_MODULE(actions, Action triggering on requests, , , most)
 APACHE_MODULE(speling, correct common URL misspellings, , , most)
-APACHE_MODULE(userdir, mapping of requests to user-specific directories, , , yes)
+APACHE_MODULE(userdir, mapping of requests to user-specific directories, , , most)
 APACHE_MODULE(alias, mapping of requests to different filesystem parts, , , yes)
 APACHE_MODULE(rewrite, rule based URL manipulation, , , most)
 

Modified: httpd/httpd/trunk/modules/metadata/config.m4
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/metadata/config.m4?rev=1201111&r1=1201110&r2=1201111&view=diff
==============================================================================
--- httpd/httpd/trunk/modules/metadata/config.m4 (original)
+++ httpd/httpd/trunk/modules/metadata/config.m4 Sat Nov 12 00:12:50 2011
@@ -8,7 +8,7 @@ APACHE_MODULE(env, clearing/setting of E
 APACHE_MODULE(mime_magic, automagically determining MIME type)
 APACHE_MODULE(cern_meta, CERN-type meta files, , , no)
 APACHE_MODULE(expires, Expires header control, , , most)
-APACHE_MODULE(headers, HTTP header control, , , most)
+APACHE_MODULE(headers, HTTP header control, , , yes)
 APACHE_MODULE(ident, RFC 1413 identity check, , , no)
 
 APACHE_MODULE(usertrack, user-session tracking, , , , [