You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by bu...@apache.org on 2003/09/23 21:33:53 UTC

DO NOT REPLY [Bug 23365] New: - DaemonController.reload() has restart() semantics

DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=23365>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=23365

DaemonController.reload() has restart() semantics

           Summary: DaemonController.reload() has restart() semantics
           Product: Commons
           Version: 1.0 Alpha
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Daemon
        AssignedTo: commons-dev@jakarta.apache.org
        ReportedBy: noa@resare.com


While writing documentation to the Daemon api I ran into this:

The only implementation of the DaemonController.reload() method that exists (in
DaemonLoader$Controller) translates it to DaemonLoader.shutdown(reload=true)
which essentially means

Daemon.stop()
System.exit()
<NEW JVM>
Daemon.init()
Daemon.start()

This is not the semantics that I would normally describe as "reload" but rather
"restart". Traditionally UNIX daemons have had a reload facility triggered by
sending a SIGHUP signal that typically made the daemon in question reload it's
configuration files and reopen it's log-files to facilitate log rotation.

Compare this with "restart" that typically shuts the service down and restarts it.

Suggestions to handle this:

a) rename reload() to restart()

b) change the semantics of reload(), adding a reload() method to the Daemon
interface and patch jsvc and procrun so that it get's called when
DaemonController.reload() and possibly a SIGHUP is recieved.

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org