You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@kafka.apache.org by "José Armando García Sancio (Jira)" <ji...@apache.org> on 2023/07/28 14:37:00 UTC

[jira] [Created] (KAFKA-15269) Clean up the RaftClient interface

José Armando García Sancio created KAFKA-15269:
--------------------------------------------------

             Summary: Clean up the RaftClient interface
                 Key: KAFKA-15269
                 URL: https://issues.apache.org/jira/browse/KAFKA-15269
             Project: Kafka
          Issue Type: Task
            Reporter: José Armando García Sancio
            Assignee: José Armando García Sancio


Make the following changes to the {{RaftClient}} interface and implementation

Remove {{scheduleAtomicAppend;}} the controller doesn't use {{scheduleAppend}} so we can revert to the original semantic.

{{logEndOffset}} is misleading when called on the leader since it doesn't include records already appended to the {{BatchAccumulator}} and have not been written to the log. Rename it to {{endOffset}} in the process.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)