You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Henri Yandell <fl...@gmail.com> on 2004/10/14 15:04:17 UTC

[lang] Re: Review for 2.1

Sorry for quietness. Life's getting pretty busy and will only get
busier in a week when the baby happens.

On Fri, 8 Oct 2004 01:09:26 +0100, Stephen Colebourne
<sc...@btopenworld.com> wrote:
> Based on JDiff -
> http://www.apache.org/~bayard/commons-lang-2.1/Commons-Lang-2.0-to-2.1/chang
> es.html
> I'm not sure I like the following changes in 2.1:
> 
> - ArrayUtils.lastIndex()
> Gets the last valid index of an array. Surely users would just call
> getLength() - 1?

+/-0. We have many other places where a semantic method exists for
something simple; so I'm not bothered either way.

> - ClassUtils.CLASS_NAME_COMPARATOR
> - ClassUtils.PACKAGE_NAME_COMPARATOR
> Although potentially useful, they seem quite specific. What about comparing
> packages using Class objects? (I've never used a Package object in my work)
> Or comparing just the short name of a class?

Not sure when I'd want to compare class names without wanting java.*
and javax.* to be special.

Anyone got a user-case for these?

> - NotImplementedException
> This now implements Nestable, with a lot of extra methods. None of the other
> exception classes in the main package have been changed. We should revert
> this change, or find a lighter weight solution that works with
> ExceptionUtils.

+1 to the view that all of our Exceptions should be the same. Why did
it have to implement Nestable and not just extend NestableXxx?

> - Validate.allElementsOfClass
> Should rename to allElementsOfType, and use instanceof style check, not
> class equals style check

+1

> Still TODO:
> - WordUtils
> Capitalize with separator methods need to define null handling for delimiter
> list, and better javadoc for two of the three methods
> 
> - DurationFormatUtils
> Still needs more work

What in particular? Possibly I just need to update the xdocs/tasks.xml :)

> - StopWatch
> Is this complete?

I think so. I'm out of new ideas on it.

> - text subpackage
> 
> Things I'm happy with:
> - CharEncoding
> - CharUtils
> - other ArrayUtsls additions (although the class is large now)
> - ObjectUtils changes
> - StringUtils changes
> - SystemUtils changes
> - Builder package changes
> - Enum rename to Enums
> - Mutable subpackage
> - NumberUtils changes
> - DateUtils changes
> 
> My thought is maybe we can do a release soon without the text subpackage?

+1

> And possibly with DurationFormatUtils still package scoped. We now have a
> customer (cocoon) wanting a release, so we should try and oblige.

Would definitely like to see it go as I think it's good now.

Hen

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org