You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@directory.apache.org by el...@apache.org on 2016/09/02 07:26:33 UTC
svn commit: r1758888 -
/directory/shared/trunk/ldap/model/src/main/antlr/distinguishedName.g
Author: elecharny
Date: Fri Sep 2 07:26:32 2016
New Revision: 1758888
URL: http://svn.apache.org/viewvc?rev=1758888&view=rev
Log:
Updated Javadocs
Modified:
directory/shared/trunk/ldap/model/src/main/antlr/distinguishedName.g
Modified: directory/shared/trunk/ldap/model/src/main/antlr/distinguishedName.g
URL: http://svn.apache.org/viewvc/directory/shared/trunk/ldap/model/src/main/antlr/distinguishedName.g?rev=1758888&r1=1758887&r2=1758888&view=diff
==============================================================================
--- directory/shared/trunk/ldap/model/src/main/antlr/distinguishedName.g (original)
+++ directory/shared/trunk/ldap/model/src/main/antlr/distinguishedName.g Fri Sep 2 07:26:32 2016
@@ -167,13 +167,13 @@ options {
* name = name-component *("," name-component)
*
* RFC 1779, Section 2.3
- * <name> ::= <name-component> ( <spaced-separator> )
- * | <name-component> <spaced-separator> <name>
- * <spaced-separator> ::= <optional-space>
- * <separator>
- * <optional-space>
- * <separator> ::= "," | ";"
- * <optional-space> ::= ( <CR> ) *( " " )
+ * <name> ::= <name-component> ( <spaced-separator> )
+ * | <name-component> <spaced-separator> <name>
+ * <spaced-separator> ::= <optional-space>
+ * <separator>
+ * <optional-space>
+ * <separator> ::= "," | ";"
+ * <optional-space> ::= ( <CR> ) *( " " )
*
*/
distinguishedName [Dn dn]
@@ -229,13 +229,13 @@ distinguishedName [Dn dn]
* name = name-component *("," name-component)
*
* RFC 1779, Section 2.3
- * <name> ::= <name-component> ( <spaced-separator> )
- * | <name-component> <spaced-separator> <name>
- * <spaced-separator> ::= <optional-space>
- * <separator>
- * <optional-space>
- * <separator> ::= "," | ";"
- * <optional-space> ::= ( <CR> ) *( " " )
+ * <name> ::= <name-component> ( <spaced-separator> )
+ * | <name-component> <spaced-separator> <name>
+ * <spaced-separator> ::= <optional-space>
+ * <separator>
+ * <optional-space>
+ * <separator> ::= "," | ";"
+ * <optional-space> ::= ( <CR> ) *( " " )
*
*/
relativeDistinguishedNames [List<Rdn> rdns]
@@ -271,9 +271,9 @@ relativeDistinguishedNames [List<Rdn> rd
* name-component = attributeTypeAndValue *("+" attributeTypeAndValue)
*
* RFC 1779, Section 2.3
- * <name-component> ::= <attribute>
- * | <attribute> <optional-space> "+"
- * <optional-space> <name-component>
+ * <name-component> ::= <attribute>
+ * | <attribute> <optional-space> "+"
+ * <optional-space> <name-component>
*
*/
relativeDistinguishedName [Rdn initialRdn] returns [Rdn rdn]
@@ -544,7 +544,7 @@ attributeValue [UpAndNormValue value]
/**
* RFC 2253, Section 3
* / QUOTATION *( quotechar / pair ) QUOTATION ; only from v2
- * quotechar = <any character except "\" or QUOTATION >
+ * quotechar = <any character except "\" or QUOTATION >
*
*/
quotestring [UpAndNormValue value]
@@ -581,9 +581,9 @@ quotestring [UpAndNormValue value]
*
* hexstring = SHARP 1*hexpair
*
- * If in <hexstring> form, a BER representation can be obtained from
- * converting each <hexpair> of the <hexstring> to the octet indicated
- * by the <hexpair>.
+ * If in <hexstring> form, a BER representation can be obtained from
+ * converting each <hexpair> of the <hexstring> to the octet indicated
+ * by the <hexpair>.
*
*/
hexstring [UpAndNormValue value]
@@ -604,7 +604,7 @@ hexstring [UpAndNormValue value]
* RFC 4514 Section 3
*
* ; The following characters are to be escaped when they appear
- * ; in the value to be encoded: ESC, one of <escaped>, leading
+ * ; in the value to be encoded: ESC, one of <escaped>, leading
* ; SHARP or SPACE, trailing SPACE, and NULL.
* string = [ ( leadchar / pair ) [ *( stringchar / pair )
* ( trailchar / pair ) ] ]
@@ -771,20 +771,20 @@ utfmb returns [String utfmb]
* escaped = DQUOTE / PLUS / COMMA / SEMI / LANGLE / RANGLE
* hexpair = HEX HEX
*
- * If in <string> form, a LDAP string representation asserted value can
- * be obtained by replacing (left to right, non-recursively) each <pair>
- * appearing in the <string> as follows:
- * replace <ESC><ESC> with <ESC>;
- * replace <ESC><special> with <special>;
- * replace <ESC><hexpair> with the octet indicated by the <hexpair>.
+ * If in <string> form, a LDAP string representation asserted value can
+ * be obtained by replacing (left to right, non-recursively) each <pair>
+ * appearing in the <string> as follows:
+ * replace <ESC><ESC> with <ESC>;
+ * replace <ESC><special> with <special>;
+ * replace <ESC><hexpair> with the octet indicated by the <hexpair>.
*
* RFC 2253, Section 3
* pair = "\" ( special / "\" / QUOTATION / hexpair )
- * special = "," / "=" / "+" / "<" / ">" / "#" / ";"
+ * special = "," / "=" / "+" / "<" / ">" / "#" / ";"
*
* RFC 1779, Section 2.3
- * <pair> ::= "\" ( <special> | "\" | '"')
- * <special> ::= "," | "=" | <CR> | "+" | "<" | ">"
+ * <pair> ::= "\" ( <special> | "\" | '"')
+ * <special> ::= "," | "=" | <CR> | "+" | "<" | ">"
* | "#" | ";"
*
*/