You are viewing a plain text version of this content. The canonical link for it is here.
Posted to users@myfaces.apache.org by Rogerio Pereira <ro...@gmail.com> on 2005/11/12 15:00:02 UTC

before start the toolbar control

Hi,

I need some advice before start the toolbar component.

1) any suggestions about the name of this toolbar component?
2) i'm thinking in 3 classes at this point (ToolBar, ToolButton and Separator)
3) the ToolButton will render a commandLink and commandButton (showing
an image) or just commandLink
4) i need sugestions about directory structure

This will help me start the development of this component.

--
Yours truly (Atenciosamente),

Rogério

Re: before start the toolbar control

Posted by Rogerio Pereira <ro...@gmail.com>.
Thanks, now i need some advice about directory structure for sources...

2005/11/12, Matthias Kahlau <mk...@web.de>:
> Hi,
>
>
> in my opinion, if your ToolButton is either a commandLink or a
> commandLink/commandButton combination, a better name for ToolButton would be
> ToolCommand or ToolCommandItem.
>
>
> Regards,
> Matthias
>
>
> > -----Ursprüngliche Nachricht-----
> > Von: users-return-12177-mkahlau=web.de@myfaces.apache.org
> > [mailto:users-return-12177-mkahlau=web.de@myfaces.apache.org]Im Auftrag
> > von Rogerio Pereira
> > Gesendet: Samstag, 12. November 2005 15:00
> > An: MyFaces Discussion
> > Betreff: before start the toolbar control
> >
> >
> > Hi,
> >
> > I need some advice before start the toolbar component.
> >
> > 1) any suggestions about the name of this toolbar component?
> > 2) i'm thinking in 3 classes at this point (ToolBar, ToolButton
> > and Separator)
> > 3) the ToolButton will render a commandLink and commandButton (showing
> > an image) or just commandLink
> > 4) i need sugestions about directory structure
> >
> > This will help me start the development of this component.
> >
> > --
> > Yours truly (Atenciosamente),
> >
> > Rogério
>
>


--
Yours truly (Atenciosamente),

Rogério

Re: before start the toolbar control

Posted by Rogerio Pereira <ro...@gmail.com>.
Since ToolCommandItem has a action attribute and commandLink and
commandButton are only generated inside ToolCommandItem i can share
the ToolCommandItem action in both command components.
I need understand a little more about data model.


2005/11/12, Yee CN <ye...@streamyx.com>:
> Hi Rogério,
>
> I like to propose not using commandLink or commandButton for the toolbar
> items, but instead look-alikes that carry an id. The whole toolbar will
> submit to one action, and within the action we will have a switch statement
> to determine which button is pressed.
>
> The reason for the proposal is ease of reuse. For example in many of my
> forms I have a standard toolbar consisting of "add, delete, edit", and
> another one consisting of "ok, cancel". With this proposal we can simply
> copy and paste a fairly complex toolbar and configure only action attribute.
>
> The next step is to load the toolbar from a data model.
>
> Eagerly awaiting.
>
> Regards,
> Yee
>
>
> -----Original Message-----
> From: Rogerio Pereira [mailto:rogerio.araujo@gmail.com]
> Sent: Saturday, 12 November 2005 10:00 PM
> To: MyFaces Discussion
> Subject: before start the toolbar control
>
> Hi,
>
> I need some advice before start the toolbar component.
>
> 1) any suggestions about the name of this toolbar component?
> 2) i'm thinking in 3 classes at this point (ToolBar, ToolButton and
> Separator)
> 3) the ToolButton will render a commandLink and commandButton (showing
> an image) or just commandLink
> 4) i need sugestions about directory structure
>
> This will help me start the development of this component.
>
> --
> Yours truly (Atenciosamente),
>
> Rogério
>
>


--
Yours truly (Atenciosamente),

Rogério

AW: before start the toolbar control

Posted by Matthias Kahlau <mk...@web.de>.
Hi,


in my opinion, if your ToolButton is either a commandLink or a
commandLink/commandButton combination, a better name for ToolButton would be
ToolCommand or ToolCommandItem.


Regards,
Matthias


> -----Ursprüngliche Nachricht-----
> Von: users-return-12177-mkahlau=web.de@myfaces.apache.org
> [mailto:users-return-12177-mkahlau=web.de@myfaces.apache.org]Im Auftrag
> von Rogerio Pereira
> Gesendet: Samstag, 12. November 2005 15:00
> An: MyFaces Discussion
> Betreff: before start the toolbar control
>
>
> Hi,
>
> I need some advice before start the toolbar component.
>
> 1) any suggestions about the name of this toolbar component?
> 2) i'm thinking in 3 classes at this point (ToolBar, ToolButton
> and Separator)
> 3) the ToolButton will render a commandLink and commandButton (showing
> an image) or just commandLink
> 4) i need sugestions about directory structure
>
> This will help me start the development of this component.
>
> --
> Yours truly (Atenciosamente),
>
> Rogério


RE: before start the toolbar control

Posted by Yee CN <ye...@streamyx.com>.
Hi Rogério,

I like to propose not using commandLink or commandButton for the toolbar
items, but instead look-alikes that carry an id. The whole toolbar will
submit to one action, and within the action we will have a switch statement
to determine which button is pressed.

The reason for the proposal is ease of reuse. For example in many of my
forms I have a standard toolbar consisting of "add, delete, edit", and
another one consisting of "ok, cancel". With this proposal we can simply
copy and paste a fairly complex toolbar and configure only action attribute.

The next step is to load the toolbar from a data model.

Eagerly awaiting.

Regards,
Yee


-----Original Message-----
From: Rogerio Pereira [mailto:rogerio.araujo@gmail.com] 
Sent: Saturday, 12 November 2005 10:00 PM
To: MyFaces Discussion
Subject: before start the toolbar control

Hi,

I need some advice before start the toolbar component.

1) any suggestions about the name of this toolbar component?
2) i'm thinking in 3 classes at this point (ToolBar, ToolButton and
Separator)
3) the ToolButton will render a commandLink and commandButton (showing
an image) or just commandLink
4) i need sugestions about directory structure

This will help me start the development of this component.

--
Yours truly (Atenciosamente),

Rogério