You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@accumulo.apache.org by "Bill Havanki (JIRA)" <ji...@apache.org> on 2014/06/24 18:10:27 UTC

[jira] [Commented] (ACCUMULO-2946) refactor namespace / table operations code to share more code

    [ https://issues.apache.org/jira/browse/ACCUMULO-2946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14042295#comment-14042295 ] 

Bill Havanki commented on ACCUMULO-2946:
----------------------------------------

Renamed to avoid confusion with ACCUMULO-2615 et al.

> refactor namespace / table operations code to share more code
> -------------------------------------------------------------
>
>                 Key: ACCUMULO-2946
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2946
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: Adam Fuchs
>            Priority: Trivial
>             Fix For: 1.7.0
>
>
> o.a.a.core.client.admin.NamespaceOperationsHelper and o.a.a.core.client.admin.TableOperationsHelper have a lot of repeated code between them. Refactor them to remove the duplication. Maybe this could be done by adding a boolean to the method signatures, representing whether we're configuring a namespace or a table?



--
This message was sent by Atlassian JIRA
(v6.2#6252)