You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@isis.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2014/01/31 11:48:12 UTC

[jira] [Commented] (ISIS-670) Replace AuditingService and AuditingService2 with new AuditingService3 API, more consistent with other APIs

    [ https://issues.apache.org/jira/browse/ISIS-670?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13887622#comment-13887622 ] 

ASF subversion and git services commented on ISIS-670:
------------------------------------------------------

Commit 49c7c05dd57be56f6d272329c3a4693a996d8a09 in branch refs/heads/master from [~danhaywood]
[ https://git-wip-us.apache.org/repos/asf?p=isis.git;h=49c7c05 ]

ISIS-657,ISIS-660,ISIS-661,ISIS-662,ISIS-663,ISIS-667,ISIS-668,ISIS-670: JDO services

ISIS-657:
- appsettings / usersettings entities also now use "Isis" as prefix to table names

ISIS-660:
- renamed InteractionFactory to InteractionService
- renamed InteractionRepository to InteractionServiceJdoRepository
- InteractionDefault and InteractionJdo now have a next() method, to create sequences of numbers
  (as used to generate the PKs for PublishedEventJdo and BackgroundTaskJdo, see below)
- Interaction#startedAt renamed to Interaction#timestamp (and #startedAt now a derived property)
- Interaction now defines a #transactionId property
- IsisTransaction now picks up its transactionId from passed-in Interaction object (if available)
  - and defers to Interaction for generation of next pub/sub event sequence if it can (else previous behaviour)
- IsisTransaction#guidId renamed to #transactionId


ISIS-661: (background service mementos, background task service)
- renamed BackgroundTaskContributions to BackgroundTaskServiceJdoContributions
- renamed BackgroundTaskRepository to BackgroundTaskServiceJdoRepository

ISIS-662: published events contributions
- renamed PublishedEventRepository to PublishingServiceJdoRepository
- renamed PublishedEventContributions to PublishingServiceJdoContributions


ISIS-663: audit entry contributions
- rename AuditEntryCountributions to AuditingServiceJdoContributions
- rename AuditEntryRepository to AuditingServiceJdoRepository

ISIS-667:
- added JdoColumnLength as central location for standard column lengths of JDO entities
- renamed AuditEntry to AuditEntryJdo
- renamed PublishedEvent to PublishedEventJdo
- changed PK for PublishedEventJdo entity to be application-defined: (transactionId,sequence)
- change to datatype of some PublishedEventJDO entities
- changed PK for BackgroundTaskJdo entity to be application-defined: (transactionId,sequence)
- factored out Util class for JDO entities
- renamed UserSettingPrimaryKey to UserSettingJdoPK

ISIS-668:
- improvements to ServicesInstallerFromConfiguration
- improved formatting of isis.properties in the todo app & simple app

ISIS-670:
- removed AuditingService, AuditingService2 APIs
- introduced replacement AuditingService3 API


> Replace AuditingService and AuditingService2 with new AuditingService3 API, more consistent with other APIs
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: ISIS-670
>                 URL: https://issues.apache.org/jira/browse/ISIS-670
>             Project: Isis
>          Issue Type: Improvement
>          Components: Core, Objectstore: JDO
>    Affects Versions: objectstore-jdo-1.3.0, core-1.3.0
>            Reporter: Dan Haywood
>            Assignee: Dan Haywood
>            Priority: Minor
>             Fix For: objectstore-jdo-1.4.0, core-1.4.0
>
>
> Following on from ISIS-667, the other services (interaction, published now use UUID instead of string for transactoinId, java.sql.Timestamp instead of long for timestamps).
> This ticket is to replace AuditingService2 with an equivalent AuditingService3 that uses these new types.
> NB: this is a breakage of applib API, and according to semver, we ought to rev Isis to 2.0.  I don't think this is justified however; the refactor is very simple for anyone that has used this API, and revving to 2.0 seems to be overkill.  Better to address in the release notes for next 1.x release.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)