You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@netbeans.apache.org by "Bo Andersen (JIRA)" <ji...@apache.org> on 2019/01/04 17:34:00 UTC
[jira] [Commented] (NETBEANS-360) Autocomplete, better name
matching
[ https://issues.apache.org/jira/browse/NETBEANS-360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16734370#comment-16734370 ]
Bo Andersen commented on NETBEANS-360:
--------------------------------------
This information should not get lost, if someone is trying to add this feature to the PHP language, from the mailing list:
https://lists.apache.org/thread.html/53e825e433962bb9fdc72dea5fe691517f5cd7c887eb365dec496686@%3Cusers.netbeans.apache.org%3E
{quote}You want a 'CompletionProvider', most likely PhpTypeCompletionProvider (although there are some other subclasses in the php/ folder). You have Set<String> getItems(FileObject sourceFile, String prefix) where `prefix` is what the user already typed. Oddly enough I see php defines it's own org.netbeans.modules.php.spi.templates.completion.CompletionProvider while I remeber being a common interface, but I'm probably thinking of csl.api GsfCompletionProvider which was used in the Javascript support. Feel free to email me directly (or to CC me when writing to the mailing list) I might have some ideas there. I suspect fuzzy search might not work immediately, as while the completion popup is shown any further edit will just filter the list (and not re-generate the list from the provider). But perhaps there is a way for force refresh that list... Anyhow, start playing with that API and see if you make progress. --emi{quote}
> Autocomplete, better name matching
> ----------------------------------
>
> Key: NETBEANS-360
> URL: https://issues.apache.org/jira/browse/NETBEANS-360
> Project: NetBeans
> Issue Type: Improvement
> Components: php - Editor
> Affects Versions: Next
> Environment: Windows 10
> Reporter: Bo Andersen
> Priority: Major
> Attachments: autocomplete_all.png, autocomplete_search.png
>
>
> I am using the Netbeans 9 beta release (RC2). I needed a method in a test-framework, and couldn't remember the exact naming, but only some part of it. Netbeans seems only to match the beginning of methods names. I know other IDEs can suggest methods based on naming-parts in a method, I think this is very useful :)
>
> Update: I added example (attachments) of usage from another IDE, for inspiration
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@netbeans.apache.org
For additional commands, e-mail: commits-help@netbeans.apache.org
For further information about the NetBeans mailing lists, visit:
https://cwiki.apache.org/confluence/display/NETBEANS/Mailing+lists