You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Wanqiang Ji (JIRA)" <ji...@apache.org> on 2019/02/26 09:01:00 UTC

[jira] [Comment Edited] (YARN-9214) Add AbstractYarnScheduler#getValidQueues method to resolve duplicate code

    [ https://issues.apache.org/jira/browse/YARN-9214?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16777728#comment-16777728 ] 

Wanqiang Ji edited comment on YARN-9214 at 2/26/19 9:00 AM:
------------------------------------------------------------

Hi, [~cheersyang], [~eepayne], [~Prabhu Joseph]

Due to different scheduler implements *getAppsInQueue* with different logic, so we need to check whether the queue is valid. In *AbstractYarnScheduler* we had two method do it, so I think we should call the another method to do it. In addition to that, I think it is a good practice to reduce the duplicate code.  So I created this issue and resolved it.

Can you help to review this?


was (Author: jiwq):
Hi, [~cheersyang] [~eepayne] [~Prabhu Joseph]

Due to different scheduler implements *getAppsInQueue* with different logic, so we need to check whether the queue is valid. In *AbstractYarnScheduler* we had two method do it, so I think we should call the another method to do it. In addition to that, I think it is a good practice to reduce the duplicate code.  So I created this issue and resolved it.

Can you help to review this?

> Add AbstractYarnScheduler#getValidQueues method to resolve duplicate code 
> --------------------------------------------------------------------------
>
>                 Key: YARN-9214
>                 URL: https://issues.apache.org/jira/browse/YARN-9214
>             Project: Hadoop YARN
>          Issue Type: Improvement
>    Affects Versions: 3.1.0, 3.2.0, 2.9.2, 3.0.3, 2.8.5
>            Reporter: Wanqiang Ji
>            Assignee: Wanqiang Ji
>            Priority: Major
>             Fix For: 3.3.0
>
>         Attachments: YARN-9214.001.patch
>
>
> *AbstractYarnScheduler#moveAllApps* and *AbstractYarnScheduler#killAllAppsInQueue* had the same code segment. So I think we need a method to handle it named *AbstractYarnScheduler#getValidQueues*. Apart from this we need add the doc comment to expound why exists.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org