You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues-all@impala.apache.org by "Boris Tyukin (JIRA)" <ji...@apache.org> on 2018/07/27 15:33:00 UTC

[jira] [Commented] (IMPALA-5654) Disallow managed Kudu table to explicitly set Kudu tbl name in CREATE TABLE

    [ https://issues.apache.org/jira/browse/IMPALA-5654?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16559900#comment-16559900 ] 

Boris Tyukin commented on IMPALA-5654:
--------------------------------------

Guys, this is really really bad idea. There are companies (like mine) that need to be able to swap tables in safely fashion and this was the only way. I spent days finding and testing this approach and now it is disabled. What do you offer instead? Did you consider that this a breaking change? what does this change improve exactly?

See my blog post on how I was planning to do it before 2.12

[https://boristyukin.com/how-to-hot-swap-apache-kudu-tables-with-apache-impala/]

 

> Disallow managed Kudu table to explicitly set Kudu tbl name in CREATE TABLE
> ---------------------------------------------------------------------------
>
>                 Key: IMPALA-5654
>                 URL: https://issues.apache.org/jira/browse/IMPALA-5654
>             Project: IMPALA
>          Issue Type: Improvement
>          Components: Frontend
>    Affects Versions: Impala 2.8.0
>            Reporter: Matthew Jacobs
>            Assignee: Gabor Kaszab
>            Priority: Major
>              Labels: kudu
>             Fix For: Impala 2.12.0
>
>
> There's no reason to allow this behavior. Managed tables create Kudu tables with the name (in Kudu) "impala::db_name.table_name". Renaming (in Impala) a managed Kudu table results in renaming the underlying Kudu table, e.g. rename table_name to new_table name results in changing the Kudu table to "impala::db_name.new_table_name". But allowing a new table to specify the kudu table name is inconsistent with the renaming behavior and just introduces opportunities for confusion.
> {code}
>   private void analyzeManagedKuduTableParams(Analyzer analyzer) throws AnalysisException {
>     // If no Kudu table name is specified in tblproperties, generate one using the
>     // current database as a prefix to avoid conflicts in Kudu.
>     // TODO: Disallow setting this manually for managed tables
>     if (!getTblProperties().containsKey(KuduTable.KEY_TABLE_NAME)) {
>       getTblProperties().put(KuduTable.KEY_TABLE_NAME,
>           KuduUtil.getDefaultCreateKuduTableName(getDb(), getTbl()));
>     }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-all-unsubscribe@impala.apache.org
For additional commands, e-mail: issues-all-help@impala.apache.org