You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "ASF GitHub Bot (Jira)" <ji...@apache.org> on 2026/03/06 06:56:00 UTC

[jira] [Updated] (HDDS-14611) Rename committed bytes to finalized key bytes and align committed space terminology

     [ https://issues.apache.org/jira/browse/HDDS-14611?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

ASF GitHub Bot updated HDDS-14611:
----------------------------------
    Labels: pull-request-available  (was: )

> Rename committed bytes to finalized key bytes and align committed space terminology
> -----------------------------------------------------------------------------------
>
>                 Key: HDDS-14611
>                 URL: https://issues.apache.org/jira/browse/HDDS-14611
>             Project: Apache Ozone
>          Issue Type: Sub-task
>          Components: Ozone Recon
>            Reporter: Priyesh K
>            Assignee: Priyesh K
>            Priority: Major
>              Labels: pull-request-available
>
> Rename {{committedBytes}} to {{{}finalizedKeyBytes{}}}, and rename totalOzonePreAllocatedContainerSpace to {{totalOzoneCommittedSpace}} to better align with existing terminology in the codebase.
> The term {{committed}} is already used consistently across the system to refer to pre-allocated container space. In storage terminology, _committed_ naturally represents space that has been offered or reserved ahead of actual usage, which makes it an accurate and intuitive choice. Reusing this term avoids confusion and improves consistency across components.
> The rename to {{finalizedKeyBytes}} also provides better semantic clarity by clearly distinguishing finalized key data from container-level committed space.
> As part of this change, update all related unit test cases and adjust the Cluster Capacity UI to reflect the new naming, ensuring consistency across backend logic, tests, and user-facing views.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org